PDA

View Full Version : changed tube and still doesnt work


joedotts
12-16-2008, 01:19 PM
I have a Fender hotrod deluxe, and one day it went dead.

I looked at the tubes and noticed that the very right small tube was not lit. I picked up a new tube and changed it. At first it worked but the amp was so quiet i turned it up to like 8 and i usually dont ever play past 3 because that is SO loud, and at 8 it was hardly loud at all. The sound faded away and now doesnt work. The brand new tube isnt lit, but i dont know if it ever was lit at all. Any help on what the problem could be??

i did have a previous problem, a year ago it kept blowing fuses, so i bought bigger fuses and it fried those, so i found a shop and it was something to do with the power. got it replaced worked great for the past year, and then it died, i also noticed that i still had the bigger fuses in there, could that be a problem??

Blue Strat
12-16-2008, 02:32 PM
NEVER use bigger fuses than required. They can't protect the amp. You may have done some serious damage.

Try one of your other tubes that's lighting up in the other sockets in V1. Does it light up>?

SatelliteAmps
12-16-2008, 04:34 PM
+1

Bigger fuses will let the amp overheat, and self destruct.

Ronsonic
12-16-2008, 10:16 PM
It would be really silly to guess at this point.

Don't ****ing feed fuses to your gear.

If it blows a fuse, replace it because it may have been a "nuisance" fuse blow. If the one you put in there blows it is telling you that something very bad is wrong, WRONG.

Get your amp to a shop, they'll fix it.

mageerc
12-17-2008, 07:32 AM
Here's a link to a site that helps with the myriad of problems associated with the Hod Rod series of amps from Fender: http://studentweb.eku.edu/justin_holton/

From your description, it sounds like you're not getting filament voltage to that tube and that is easy enough to check. You may have a bad solder joint on that tube socket, a dirty or damaged socket. The boards on this series of amps are strictly flimsy and I can't stress enough the care you need to use when soldering on these boards. The solder pads are just pitiful! They are nothing but a piece of foil and just a little too much heat will damage it to the point that you'll have to put a jumper around that pad.

Have fun! These are not an easy to work on amp, but Justin's site gives you some insight in the how to...