Super Reverb Crackling

Discussion in 'Amps and Cabs' started by sixstring531, Apr 7, 2007.

  1. sixstring531

    sixstring531 Supporting Member

    Joined:
    Mar 8, 2007
    Messages:
    2,535
    Location:
    Southwest Missouri
    My Fender Super Reverb '65 RI is crackling. I have heard this is sometimes due to the preamp tubes, I have changed them (have not done the 12at7s yet, doing that this week) the power tubes are newer JJs and the rectifier is the RUBY one (I kNow they suck) that came with the amp.

    The crackles sound like an old record player and happen even when the guitar is not plugged in. I think it may be possessed. Do I need a priest?

    Any suggestions what this might be? Tips are welcome.
     
  2. K-Line

    K-Line Gold Supporting Member

    Joined:
    Jun 24, 2006
    Messages:
    5,479
    Location:
    St. Louis, Missourah
    I have the same problem with my 66 Pro Reverb. I was told to check the tubes and clean the pots!? I am not an amp guy but will be tuning in to the suggestions as well.
     
  3. Austinrocks

    Austinrocks Member

    Joined:
    Feb 10, 2007
    Messages:
    7,048
    When you say you disconnected the guitar, hopefully you did not leave the cable connected to the amp, that will cause all kinds of noise. Noise is often caused by a bad cable, you might replace the cable if you have one laying around.

    Crackling an popping can be a sign of worn out tubes, turn on the amp with out the cable connected to the amp input and tap the tubes with a wooden stick, if any of the tubes make a loud pop when they are hit, its a sign of a bad tube, preamp tubes you can replace individually, Power amp tubes need to be replaced with matched pairs, and may need to have the bias set for the new power tubes. Preamp tubes don't need to be biased.
     
  4. sixstring531

    sixstring531 Supporting Member

    Joined:
    Mar 8, 2007
    Messages:
    2,535
    Location:
    Southwest Missouri
    I didn't disconnect the cable from the guitar when it was still on. What kind of a person do you think I am. I have done the tapping and that is not it. I am going to buy some new cables next. The one I am currently using is about 10 years old.
     
  5. Fretts

    Fretts Member

    Joined:
    Nov 20, 2003
    Messages:
    330
    Location:
    Santa Monica, CA
    The weirdest reason for crackling I have ever encountered was a bad rectifier tube, believe it or not. I tightened the tube socket, cleaned the contacts, still no improvement. I swapped out the rectifier and... instant cure... go figure. Try it, it just might be your problem.
    If you live in a humid environment, the black fiber eyelet board can absorb moisture and conduct electricity along trails of dust and debris on the underside. This is a pain to fix, you have to unsolder some wires, lift the board and clean it out. Later Fenders dipped the whole board in wax ( I presume) to prevent this.
     
  6. gtrshow

    gtrshow Member

    Joined:
    Feb 12, 2006
    Messages:
    791
    Location:
    Near Ottawa, Canada
    I'm having exactly the same problem with my '71 Vibrolux Reverb as of yesterday. Weird. Must be something in the atmosphere. Either that, or time for a new amp! :D
     
  7. jezzzz2003

    jezzzz2003 Senior Member

    Joined:
    Dec 6, 2005
    Messages:
    2,797
    Location:
    aussie
    Sounds like filter caps.
     
  8. sixstring531

    sixstring531 Supporting Member

    Joined:
    Mar 8, 2007
    Messages:
    2,535
    Location:
    Southwest Missouri
    How does one go about cleaner or getting new filter caps and how much does it cost?
     
  9. Mr. Kite

    Mr. Kite Supporting Member

    Joined:
    Nov 17, 2005
    Messages:
    4,566
    Location:
    Seabrook, TX
    There are certain lights in my house that have to stay off when my amps are on. If my wife turns them on I get crackling and popping noises. Some give a steady zzzzzzzzzzz.
    My.02
    Edit: I'm not sure if it has a tremelo channel but if it does and you are plugged in to it try changing the speed and intensity and see if that makes a difference in the sound. Might help narrow it down.
     
  10. JimmyR

    JimmyR Member

    Joined:
    Jul 22, 2006
    Messages:
    3,802
    Location:
    sub lacum
    If it's a Super Reverb RI then it won't be the fibreboard absorbing moisture cuz there ain't one! Sounds very much like a tube to me. Also as it's a RI then it's unlikely to be filters. If it's not a tube then it's a dry joint, a dodgy socket (input or tube) or one of the ribbon connectors is loose.

    But I really think it's a tube.
     
  11. sixstring531

    sixstring531 Supporting Member

    Joined:
    Mar 8, 2007
    Messages:
    2,535
    Location:
    Southwest Missouri
    Could this be one of the vibro or reverb tubes? I am changing those this week. i just changed the four 12ax7s and the power tubes are newer jjs. I will change the rectifier tube this week as well. I was told i can spray some contact cleaner into the sockets (when unplugged of course) to help clean things out. What exactly does the rectifier tube do anyway and would it be this one?
     

Share This Page