• TGP is giving away a Strat, Tele, and Jazzmaster. Click Here for full details.
    Click Here to upgrade your account and enter today!

Recent content by TheAmpNerd

  1. T

    Tweed vibrolux troubleshooting

    that is good that it wasnt worst case. : )
  2. T

    Howdy

    That's right, Howdy ya'll. Haven't been here in many moons squared. Hope you'all are doing well and I see we are still alive and well. What new has been happening? What fun has been happening? I see guys like WaltC and blue are plugging away. Cheers, Spiike
  3. T

    Tweed vibrolux troubleshooting

    Bummer, + 2 What the other's have said. Worst case: Including, that power transformer is beyond the end of its useful life. The enamel coated wire in the transformer may have degraded to the point where the heaters no longer work. It may be time for a rewind or buy a new power transformer...
  4. T

    Tracking down parasitic oscillation

    Don't feel bad brother. Sometimes I take years to figure out. Sometimes you never do. Your just too close to see it and you don't feel like messing with it. Read up on the Dumble guy and the Trainwreck guy. Both them had amps sitting around...Ken I think never messed with one of his...
  5. T

    AC30 Wiring Layout

    I should have realized this sooner. The replaced pot, the TremVol pot was damaged. Don't know if the unit came that way or damaged in shipping who knows. But when I got the amp it was in there and always was causing problems, unbeknownst to me. So a little bit of clean and removal along with...
  6. T

    Anybody ever use the Billm mods for their Blues JR.

    I did the mods on a friends amp. It really made a difference along with a new speakers. Unfortunately, I also told him I wouldn't keep the crappy output tubes in that amp. He should get some good new or NOS and just suck it up and pay the money. I think three to six months later he gave me a...
  7. T

    AC30 Wiring Layout

    Here is the AC30 that I've got and gave up on and recently working on it again. These are pics from the late 80s hand wired LTD edition from what I can tell. Interestingly I found some other pics of one on the net and it is slightly different than the with the GZ34. To note these are the...
  8. T

    AC30 - tube layout? - photos

    Yeah, your memory is pretty good, especially in dealing with the definitive British amp. The tube numbering scheme would make even Spock cringe though. I'll post a real treat for you over on my thread.
  9. T

    AC30 Wiring Layout

    I'm thinking the problem may be with the normal volume pot, Center tab thru 220K connects to the 500pf cap at A17 Right tab connects to .047uf cap on A 26. Or Is this a pretty standard issue with the AC30? (CD7 is there for fitting purposes, not soldered in.) And the right side here...
  10. T

    AC30 - tube layout? - photos

    That is a whole lotta fun in that amp.
  11. T

    AC30 Wiring Layout

    I'll have to post some pics. Trying to resurrect an old AC30. Not that old, is the SS rectifier one. Horrible hum, and pots/parts replaced prior... ...I'm trying to sort it all out here. For now, this is where I'm at... voltages are +-10/20 percent, in spec. vib/trem vol and brillant vol...
  12. T

    issue with '72 Deluxe Reverb

    Hi Guys, I would make sure to change out the white electrolytic in the trem circuit. I've seen more than a few of these blow up in an amp. The are a real mess to clean up too. Have fun and make music.
  13. T

    Ampeg SVT Bias...

    Ronsonic, Will do and I'll let you know the result. The Nerdy One
  14. T

    Ampeg SVT Bias...

    Clarifications, Bias fine with no signal; my bad it has a load. Also the amp is in spec during idle conditions. Then when a signal applied, the one side will not balance up. All the componant parts test and measure out fine. I also replaced the plate load resistors with new 600 ohm instead...
  15. T

    Ampeg SVT Bias...

    Hi y'all: Gotta quick Ampeg Bias problem. The amp is within spec with no load. .072 v on the power tubes and balances fine. I changed the bias sense resistors to 10 ohms. So it is all happy until you run your test signal through it and it the bias goes to hell with 1/2 the output tubes...
Top