Search results

  1. Blue Strat

    Rectifier tube problem

    NOS EZ81s are only about $30 from a legit dealer with a warranty. A problem in the amp COULD cause arcing. Not sure exactly why the Copper Cap would be immune (or how you'd know since you can't see inside), but often arcing in a rectifier is just a start up condition where there's a lot of...
  2. Blue Strat

    Online Tube Dealer Sticky

    Woah! That's amazing!
  3. Blue Strat

    Help with mismatched tubes

    Scenario B. While there's no idea setup, that one's the best. And it doesn't matter which of each pair of left/right sockets either tube (high or low) goes in, because the left and right pairs are in parallel. Regarding hum, I defy anyone to find a pair within 8mA that hums, and scenario B is...
  4. Blue Strat

    help troubleshooting Deluxe Reverb reverb hum

    Does the hum stop with the footswitch unplugged from the back of the amp?
  5. Blue Strat

    What RCA tube is this?/My Bassman Problems

    Or even when they don't die.
  6. Blue Strat

    What RCA tube is this?/My Bassman Problems

    When you say "modded", what does that mean? Usually it means that the design has been changed. Is it that, or were there parts replaced with the correct replacements? So far, there's not nearly enough information to go on...but if you suspect a tube the only way to be sure is to replace it...
  7. Blue Strat

    6v6 tube replacement for princeton reissue

    The Tung Sols, on average, aren't very robust. Whatever you use, don't forget that they need to be biased properly regardless of the missing bias pot in the amp. Either have a tech install a pot or pay for the time to swap out bias resistors every time you replace tubes. FWIW, there are several...
  8. Blue Strat

    Please Help, 68 Deluxe reverb reissue acting weird

    First things first. Disconnect EVERYTHING except the guitar amp and cord and try again. Everything ok? If not, try the other channel. If everything is ok, add ONE extra thing (footswitch cable, THD, etc) at a time until the problem recurs.
  9. Blue Strat

    Tube plates

    It's not simple, no generalizations work across all manufacturers/brands, and the tube designers of the day would think that we're insane for noticing tonal differences at all. :)
  10. Blue Strat

    JJ 6V6S cooler bias?

    Yeah, crossover distortion doesn't occur until WAY below 50%...I don't recall exactly what % though. There's no chance of missing it, sonically, when it occurs.
  11. Blue Strat

    Can you test tube matching with bias probe?

    If neither of the 2 tubes were noisy, which has nothing to do with matching, you would've been fine. Don't confuse the missing test minutia, mentioned by some, with tubes that can't be used due to noise. Those are 2 entirely different criteria.
  12. Blue Strat

    Princeton Reverb Mojotone kit finished but no audio

    Awesome Rey, happy to help! FWIW, we continued using his guitar as a signal generator and his meter, set to AC volts, as the "scope". Due to meter limitations, the direct guitar signal was almost too low to "see" on the meter...but just enough to know it was there. The meter DID have a hard...
  13. Blue Strat

    JJ and Eurotubes tube ratings?

    In general, numbers from one dealer won't align with numbers from another dealer unless they're both using the same, equally calibrated, tester...which is rare. You'll have to ask whoever you got the tubes from.
  14. Blue Strat

    Can you test tube matching with bias probe?

    Short answer: Yes. Anything more is largely a waste of time.
  15. Blue Strat

    Princeton Reverb Mojotone kit finished but no audio

    Something's wrong. Maybe the meter, connections, communications...those readings don't make any sense. Find the 500pf cap that goes from the 3.3M to the 12AT7. Disconnect it and see if that helps at all.
  16. Blue Strat

    Princeton Reverb Mojotone kit finished but no audio

    Yeah, I'd love to refer to the schematic but that's not gonna help, I'm afraid.
  17. Blue Strat

    Princeton Reverb Mojotone kit finished but no audio

    Seriously? As in, functioning normally or malfunction?
  18. Blue Strat

    Princeton Reverb Mojotone kit finished but no audio

    Ok, back up a minute. When taking all of these measurements the black meter lead should be connected to ground ALWAYS. The pin 1, 6 and 3.3Meg readings are done with the RED lead in those places and the black lead connected to ground (chassis should work). Is this what you were doing or not? Let...
  19. Blue Strat

    Princeton Reverb Mojotone kit finished but no audio

    Nope, doesn't make sense. It should read 0 volts AC unless you're strumming the guitar. I hate to say it, but it's bad enough being partially blind in troubleshooting over the web...but if this meter thing isn't working we're totally blind. Do you have an amp tech locally? You may have to...
  20. Blue Strat

    Princeton Reverb Mojotone kit finished but no audio

    I'm hoping his meter is autoranging and the reading was more like 3.5 volts than 325. BTW, giving pin numbers is probably going to be more useful.
  21. Blue Strat

    Princeton Reverb Mojotone kit finished but no audio

    PS, if the signal is gone at the 3.3M, try removing the wire to the 500pf capacitor, or just remove one end of the capacitor from the board or wherever it's connected.
  22. Blue Strat

    Princeton Reverb Mojotone kit finished but no audio

    Woah! That's BIG! Sure it's 325V? That seems like a lot. Does it return to around zero? Just trying to confirm your test method/instrument here. If yes, try probing both sides of the 3.3 Meg resistor. Wherever you lose it, the problem is between the last place you saw it and the first place you...




Trending Topics

Top