6v6gt grid leakage

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by ramonneke76, Jan 28, 2015.

  1. ramonneke76

    ramonneke76 Member

    Messages:
    198
    Joined:
    Dec 31, 2012
    Hi,

    I have an old Dynacord Twen. All the tubes still original Dynacord tubes. I tested the 6v6gt's and one tested bad for grid leakage on my Sencore TC154. I already ordered a new set of 6v6gt tubes but I am curious what could happen when I keep playing with the bad tube. Could it damage something?
     
  2. Blue Strat

    Blue Strat Member

    Messages:
    30,033
    Joined:
    Aug 2, 2002
    Location:
    Sterling, VA (not far from Washington DC)
    If it's causing bias to drift (you can check this) then yes. It could make the tube run into meltdown, melt down, and take out components in the amp.
     
  3. ramonneke76

    ramonneke76 Member

    Messages:
    198
    Joined:
    Dec 31, 2012

    Thanks.

    Just put in the new 6v6gt's. Didn't adjust the bias jet but my first impression is that the sound was not that good. Sounds a bit thin and way more hum. Hope it gets better after the bias adjustment.
     
  4. Blue Strat

    Blue Strat Member

    Messages:
    30,033
    Joined:
    Aug 2, 2002
    Location:
    Sterling, VA (not far from Washington DC)
    Hum could indicate a mismatch or maybe bias being too hot. Could also be a defective tube. Don't assess until you've checked/set the bias.
     
    Last edited: Jan 30, 2015

Share This Page