AC15 troubleshooting advice needed

Discussion in 'Amps and Cabs' started by Zack.LW, Apr 24, 2016.

  1. Zack.LW

    Zack.LW Member

    Messages:
    1,162
    Joined:
    Mar 30, 2016
    I usually play through the normal channel of my AC15 for a really clean base but i was setting up for sound check and the volume was really low. The tube is warming up just fine and glows but still low volumes with everything cranked. So I ended up swapping to the top boost channel rather than going out to get a tube (show must go on). Weirder stuff started happening.

    The volume on the top boost channel was significantly louder so I figure it's just a bad tube on the normal channel so I'll keep it here for today and then swap the tubes when I get home. Midway through the show, I kick on the favorite button on my bsr and everything gets insanely loud. Our sound guy adjusted accordingly but it was still considerably loud and overdriven sound coming from the amp.

    So what I initially thought was just a bad normal channel tube may be more than that. I don't really know what could have caused this... I was hoping one of you might have some troubleshooting tips before I just go take it into get it looked at.
     
  2. Wirezz

    Wirezz Member

    Messages:
    864
    Joined:
    Sep 2, 2015
    Probably a bad tube on the normal channel. Insanely loud sounds like my vox ac15 :)
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice