amp not producing sound

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by IbanezAFS75, May 19, 2008.

  1. IbanezAFS75

    IbanezAFS75 Member

    Messages:
    246
    Joined:
    Sep 25, 2006
    Location:
    Terryville, CT
    got my cab today (Mesa 2x12, not my favorite choice for what i wanted in a cab, but i got a good deal from my cousin). So he brings my amp in and hooks it up before i got there, turns it on, lets it warm up and switches off from standby and theres no sound at all.

    the indicator light is working, but no sound. Now he didnt mess with the ohm selection on the back, it was set at 8 and each speaker is set at 8 ohms, now i know this isnt right. Could not having it on the right ohm setting produce no sound?

    i also just stuck a new rectifier tube in it today as the one it came with smashed during shipping. its a JJ GZ34.

    The fuse isnt blown, if that makes things look better.

    Its a Metro JTM45 running on KT66's FYI.
     
  2. phsyconoodler

    phsyconoodler Member

    Messages:
    4,351
    Joined:
    Jul 11, 2005
    Location:
    calgary canada
    There should be two fuses on the rear panel.One mains fuse of about 3 amps and one HT fuse of about .5amps or 500ma.The light will come on if the HT fuse is blown,but there will be no sound.Also check the speaker cab and make sure it is working.The impedance has no bearing on whether it makes sound.
     
  3. IbanezAFS75

    IbanezAFS75 Member

    Messages:
    246
    Joined:
    Sep 25, 2006
    Location:
    Terryville, CT
    Thanks for your input, i only see one fuse on the back panel that says 2 Amps on it.

     
  4. IbanezAFS75

    IbanezAFS75 Member

    Messages:
    246
    Joined:
    Sep 25, 2006
    Location:
    Terryville, CT
    Come to think of it, i just put a JJ GZ34 Rec tube in it as it was advertised as being the same thing as a 5ar4, is this true? it originally had a 5ar4 in it. Could this pose any problem?
     
  5. doc

    doc Member

    Messages:
    5,733
    Joined:
    Jan 26, 2005
    Location:
    Middle Tennessee
    Make sure your speaker cable is okay. If possible try it with another cab that you know is fine. The impedence being off as you describe shouldn't keep it from making some sound.
     
  6. IbanezAFS75

    IbanezAFS75 Member

    Messages:
    246
    Joined:
    Sep 25, 2006
    Location:
    Terryville, CT
    I'm pretty sure it s my head, i tried the cab with my cousins head and it worked fine. thank you though, i appreciate the help.
     
  7. Blue Strat

    Blue Strat Member

    Messages:
    30,036
    Joined:
    Aug 2, 2002
    Location:
    Sterling, VA (not far from Washington DC)
    GZ34 = 5AR4.

    Could still be a bad rectifier, or blown internal HT fuse, or a preamp tube, or......
     
  8. myfoot

    myfoot Member

    Messages:
    61
    Joined:
    Jul 30, 2007
    Location:
    Illinois quad cities
  9. IbanezAFS75

    IbanezAFS75 Member

    Messages:
    246
    Joined:
    Sep 25, 2006
    Location:
    Terryville, CT
    hey guys, thanks for all your help.

    i feel like a dork, but i got it working, i must have had it hooked up wrong but now its working and sounding great,

    however, i'm not sure what the cab ohm setup it, i had it at 16 and it sounded great, i hope i didnt screw anything up, both speakers are 8 ohms but i dont know how its wired.

    any ideas on how to identify what it is?

    one more question though, i noticed on the standby theres three different notches, what is the middle selection for? i've never had an amp with this before, how does it work?

    heres a picture so i can show off its beauty :)

    [​IMG]
     
  10. rockon1

    rockon1 Member

    Messages:
    11,499
    Joined:
    Aug 12, 2005
    Location:
    Stamford CT
    If you have a multi meter it will read about 14-15 ohms resistance if the two 8 ohm speakers are wired in series. 3-4 ohms of they are wired in parallel.

    If not just physically check to see if its wired in series or parallel

    parallel

    [​IMG]

    series

    [​IMG]
     

Share This Page