1. The Gear Page is run by musicians for musicians. We listen, we learn and if we misstep we are not afraid to do the right thing. We proposed some changes to the Emporiums. Based on feedback from members, we have decided to not go ahead with those changes. However, it has also highlighted that we need some community input into what is working and what is not working for members here. Primarily focused on the Emporiums, we'd like input on your thoughts about TGP and how things work in the Emporiums for you and how you'd improve them. The discussion thread on the is here!

    Dismiss Notice

Amp popping when stand-by switch is engaged

Discussion in 'Amps and Cabs' started by James, Sep 15, 2008.

  1. James

    James Member

    Messages:
    2,759
    Joined:
    May 14, 2006
    Location:
    Boston
    Hello,

    My amp is making a popping noise whenever I engage or disengage the stand-by switch. What are the common causes of this? It used to be dead-quiet when the stand-by switch was used.

    Thanks,

    James
     
  2. sdgvintage

    sdgvintage Member

    Messages:
    345
    Joined:
    Jan 27, 2005
    Location:
    Bristow, VA
    is it a tube rectifier amp?

    I have seen certain rectifiers do that. Swapping in a different rectifier fixed it.
     
  3. 3 Mile Stone

    3 Mile Stone Silver Supporting Member

    Messages:
    5,755
    Joined:
    Apr 3, 2007
    Location:
    New Braunfels Texas
    Bumping for more info. I have heard this on occasion and it has concerned me too.
     
  4. FrankieSixxxgun

    FrankieSixxxgun Member

    Messages:
    3,044
    Joined:
    Aug 26, 2008
    Location:
    Tampa, FL
    It's too early for me to remember the exact name of the caps in the amp, not the filter caps, but that usually means they're bad. It's not a big deal, but if you replace 'em you'll get rid of the pop. Mine pops too, but I just don't care enough to fix it.
     
  5. Structo

    Structo Member

    Messages:
    9,573
    Joined:
    Apr 10, 2007
    Location:
    Oregon
    I think it is caused by where the switch is placed in the circuit.
    If it is before the caps or after the first cap in the filter.
     
  6. James

    James Member

    Messages:
    2,759
    Joined:
    May 14, 2006
    Location:
    Boston
    Thanks for your replies, mates! Yes, it's a tube amp (Allen Old Flame) with a tube rectifier.
     
  7. ChickenLover

    ChickenLover Member

    Messages:
    1,696
    Joined:
    Sep 7, 2006
    Location:
    Florida
    In just about every case the Standby switch is rated for 125v or maybe 250v and in guitar amps it is used to switch the B+ which is often ~450v. Very often all that it needed is a .01uF/1000v cap across the SB switch...some builders add them as a matter of course.
     

Share This Page