Another TimeFactor crap-out

Discussion in 'Effects, Pedals, Strings & Things' started by mattmccloskey, Dec 16, 2009.


  1. mattmccloskey

    mattmccloskey Supporting Member

    Messages:
    4,899
    Joined:
    Jan 4, 2002
    Location:
    philadelphia
    I have enjoyed the overall sound quality and numerous options and settings of my Timefactor.

    That said, I am getting skeptical of the quality. My first TF had to go back (right out of the box) because the tap tempo did not work.

    Now my second one after just 2 months is malfunctioning. The left side footswitch is dead. I can't engage preset 1 on any bank.

    So I sent it to Eventide for a repair. They are swapping out all 3 switches, which is nice, but between these 2 pedal shipments I am out 30 bucks within 60 days of my purchase for faulty units.

    Anybody else experience issues with the Eventide pedals in such a short time?
     
  2. sutherland

    sutherland Supporting Member

    Messages:
    2,866
    Joined:
    Jun 22, 2009
    Location:
    Portland, OR
    I bought a brand new Modfactor that had a faulty bypass switch and I wasn't able to perform any updates on a new Timefactor (even though the support software said there was one available).

    It is there first foray into stompbox effects, perhaps in future versions we'll have a more solid unit?
     
  3. mmcm4

    mmcm4 Member

    Messages:
    1,433
    Joined:
    Mar 22, 2009
    Location:
    ATL
    my timefactor and modfactor have worked perfectly. no breaking switches or anything.
     
  4. mrbuddy

    mrbuddy Active Member

    Messages:
    35
    Joined:
    Dec 9, 2009
    ha, this morning I tried again to update my TimeFactor to no avail.
     
  5. soli528

    soli528 Silver Supporting Member

    Messages:
    5,494
    Joined:
    Jul 18, 2006
    Location:
    Decatur, GA
    I've had two, still have one, neither have ever had a single issue. Built like a tank they are (cue Yoda voice).
    edit: Both of mine are relatively early serials... 211 and 264. Perhaps the issue is in recent models?
     
    Last edited: Dec 16, 2009
  6. pulse.

    pulse. Silver Supporting Member

    Messages:
    2,060
    Joined:
    Apr 29, 2007
    Location:
    Heraklion, Greece
    I had some issues with the tap switch on my TF too
    sometime ago, but now is ok, now I'm having problems
    with the bypass switch.

    ARGG
     
  7. Turiguiliano

    Turiguiliano Member

    Messages:
    888
    Joined:
    Sep 16, 2005
    Location:
    Rivendell
    The modfactor's tap switch isn't working properly. I have to step on it twice or thrice for it to engage. So I got an external aux switch made by this1smyne so i can assign it to that instead.
     
  8. enocaster

    enocaster Member

    Messages:
    5,090
    Joined:
    Jul 20, 2007
    Location:
    The Berkshires, MA
    My left switch is becoming intermittent.
     
  9. forum_crawler

    forum_crawler Member

    Messages:
    6,939
    Joined:
    Aug 14, 2008
    Location:
    Winnipeg, MB
    Do the right thing, get a Damage Control Timeline instead.
     
  10. mattmccloskey

    mattmccloskey Supporting Member

    Messages:
    4,899
    Joined:
    Jan 4, 2002
    Location:
    philadelphia
    ok it seems there is a trend with the switches. perhaps they should consider a different switch manufacturer.
     
  11. theanalogdream

    theanalogdream Supporting Member

    Messages:
    2,289
    Joined:
    Mar 19, 2008
    I've had mine for over a year and it's been fine...and it takes a beating!
     
  12. Chadley

    Chadley Supporting Member

    Messages:
    2,701
    Joined:
    Oct 24, 2005
    Location:
    Modesto, CA
    There is the possibility of any switch on any pedal crapping out. It is mechanical and has moving parts and you constantly put pressure on it with your foot.

    The build quality of the Eventide units is top shelf. I certainly don't think that a few people talking about it online makes it a trend.

    The real question is this: How has the customer service of Eventide been when dealing with issues? From what I have read here, it seems pretty good.
     
  13. mattmccloskey

    mattmccloskey Supporting Member

    Messages:
    4,899
    Joined:
    Jan 4, 2002
    Location:
    philadelphia
    well, the switches clearly did not malfunction due to 'being stomped on'. One was DOA, the second happened within a couple weeks of extremely gentle use.

    As to eventide service, we will see. I did have to pay shipping there (whereas some small builders will send a call tag), and the response said it may take a month to get back.

    As far as a trend, I only stated it 'seems' to be one, judging by "what I have read here" as you said.
     
  14. Stormbringer

    Stormbringer Member

    Messages:
    1,303
    Joined:
    Jan 6, 2009

    This, never had a problem at all.
     
  15. Cirrus

    Cirrus Member

    Messages:
    2,460
    Joined:
    Oct 23, 2009

    Nor I with time or modfactors...
     
  16. ItsaRat!

    ItsaRat! Member

    Messages:
    850
    Joined:
    Sep 17, 2009
    Location:
    Kalamazoo, MI
    I had a problem with my left side preset switch, and Eventide was awesome. They told me when they shipped it, were highly communicative, and even covered it under warranty though it was just out of the warranty period. They also threw in a manual which for some reason I hadn't received originally. I was really happy with my experience overall.
     
  17. Chonny

    Chonny Senior Member

    Messages:
    3,225
    Joined:
    Jul 16, 2009
    Location:
    Oklahoma City
    Wow they arent paying for your shipping?
     
  18. mattmccloskey

    mattmccloskey Supporting Member

    Messages:
    4,899
    Joined:
    Jan 4, 2002
    Location:
    philadelphia
    No. They will cover the return shipping, but not shipping to them.
     
  19. Reckedtrek

    Reckedtrek Member

    Messages:
    1,113
    Joined:
    Feb 27, 2007
    Location:
    Massachusetts
    Same experience here, as well. I've been 100% problem free thus far. :aok
     
  20. Reckedtrek

    Reckedtrek Member

    Messages:
    1,113
    Joined:
    Feb 27, 2007
    Location:
    Massachusetts
    Most of the time from posts I've seen here and on the Eventide forums, SW update issues are either user error or have an easy workaround to get the update to work properly. I'm not saying yours is definitely one or the other- but have you checked the document on the Eventide stompbox forum regardng SW update difficulties? It seems to address most update issues, and hopefully yours.
     

Share This Page