Anyone have any experience with the Eventide Timefactor loop function?

Discussion in 'Digital & Modeling Gear' started by blood5150, Jan 15, 2008.

  1. blood5150

    blood5150 Member

    Messages:
    5,646
    Joined:
    Dec 25, 2007
    Location:
    Northern NJ
    How is it?

    I just ordered one today and am looking forward to exploring this option since I never owned a looper before...
     
  2. NoFi

    NoFi Member

    Messages:
    25
    Joined:
    Jul 10, 2007
    Location:
    France
    Not that good because of the mix button, you cant get your original sound and the recorded sound at normal levels : you have to set them at 50%. That was with revision one of the software though.
     
  3. blood5150

    blood5150 Member

    Messages:
    5,646
    Joined:
    Dec 25, 2007
    Location:
    Northern NJ
    I just ordered it today... do you think it will come pre-loaded with Rev.2 or will i still have to download it?
     
  4. Teahead

    Teahead Member

    Messages:
    1,377
    Joined:
    Dec 12, 2005
    Location:
    Northern Ireland
    It will likely arrive with version 1.1, but even with the beta 2 there's still issues with the loop and direct volume. I have some clips of the Timefactor looping in my sig, if you want to hear it.

    To be honest, I didn't notice much of a problem before upgrading to beta 2, not sure why, I downgraded again but the problem persists. It's quite annoying and thus far almost managing to ruin my Timefactor experience.
     
  5. blood5150

    blood5150 Member

    Messages:
    5,646
    Joined:
    Dec 25, 2007
    Location:
    Northern NJ
    clips sound cool.. cant wait for mine..

    you are definately using an expression pedal and an EH HOG on some of those clips right?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice