Basic Helix Advice Needed

Lt_Core

Member
Messages
2,900
Hi everyone,

I have a Helix LT and I can never get enough volume when going direct to a small mixer (XLR or 1/4) or Adobe Audition for recording (USB). I have my output set to Multi Output and increasing the output level doesn't do anything in Audition. I have to really increase the volume in Audition to get it to match other inputs like keys, microphones, etc. Then the meter gets into the red and starts clipping.

Please note that I'm new to home recording as well so any advice would be great, thank you :)
 

Lele

Member
Messages
1,874
I have a Helix LT and I can never get enough volume when going direct
Aleclee is right, I think it's a matter of output type.
In your Helix, under the Global Settings, Ins/Outs, you will find the separate settings of the 1/4" outputs and the XLR outputs: if the parameter is "line" you get the hottest signal, if the parameter is "mic" or "instrument" you get a weaker signal.
But it's weird anyway, because generally with cheap mixers I have to set those parameters on the "mic/instrument" setting if not my signal is too hot.
And then you say that you have the same problem through the USB: do you mean connecting your PC to the Helix via USB?
In that case, if I'm not mistaken, there are no global settings about the output volume level, and I'm afraid there is something else that has to be set up properly. Do you use the Helix Asio drivers in your DAW (Audition)?
 

Lt_Core

Member
Messages
2,900
Is your Helix output set to line level or instrument? That would affect your mixer issue.

Thx, I will check this in the morning. Appreciate the help!

Aleclee is right, I think it's a matter of output type.
In your Helix, under the Global Settings, Ins/Outs, you will find the separate settings of the 1/4" outputs and the XLR outputs: if the parameter is "line" you get the hottest signal, if the parameter is "mic" or "instrument" you get a weaker signal.
But it's weird anyway, because generally with cheap mixers I have to set those parameters on the "mic/instrument" setting if not my signal is too hot.
And then you say that you have the same problem through the USB: do you mean connecting your PC to the Helix via USB?
In that case, if I'm not mistaken, there are no global settings about the output volume level, and I'm afraid there is something else that has to be set up properly. Do you use the Helix Asio drivers in your DAW (Audition)?

Thx for the help. The Helix is showing up in my track input list. I’m selecting 0/1 out of the 8 possible inputs. Not sure if that’s right. I’ll check out those Asio drivers in the morning. Are those PC only? I’m on a MacBook Pro. Appreciate the help!
 

Lele

Member
Messages
1,874
Are those PC only? I’m on a MacBook Pro.
I use a Windows PC. To be honest, I don't know how a Mac works.

I’m selecting 0/1 out of the 8 possible inputs.
It should be right. The first two channels are the standard output.

Just one last point: check the output block of your Helix patch (I mean the last block you will find in your patch, that is the output): is the level at 0 (that is the default and correct value)? Is that output block working on all the Helix connections (xlr, 1/4", and so on)?
Or you can send me your patch and I will check if there is anything weird.
(just send me a message here using TGP and I will give you my mail address)
But I'm afraid that it's more a matter of configuration of your Mac/daw or the global settings of your Helix.
 
Messages
1,096
I received my Helix LT yesterday, and the lower levels is the first thing I noticed running it into my Motu M4. I run both line outs into channels 3 and 4 on the Motu. I checked everything in the global settings per the advice I've seen here and elsewhere, making sure they're set to "line".

The only way I've found to get acceptable levels is to add a gain block to the end of every patch and crank it up to 12+db. That doesn't seem like something I should have to do, though.
 

aleclee

TGP Tech Wrangler
Staff member
Messages
13,666
The only way I've found to get acceptable levels is to add a gain block to the end of every patch and crank it up to 12+db. That doesn't seem like something I should have to do, though.
So your peaks without the boost are ~-20dB?
 

Fireproof

Nobody's fault but mine
Platinum Supporting Member
Messages
4,535
Thx, I will check this in the morning. Appreciate the help!



Thx for the help. The Helix is showing up in my track input list. I’m selecting 0/1 out of the 8 possible inputs. Not sure if that’s right. I’ll check out those Asio drivers in the morning. Are those PC only? I’m on a MacBook Pro. Appreciate the help!

Check out page 55 in the manual. You should be choosing channels 1/2 or 3/4 or 5/6 for processed signal. 1/2 is pretty typical. 7/8 are the ‘dry signal’ for re-amping purposes.

Also - you don’t need the ASIO drivers for a MacBook Pro - that’s for Windows. So don’t worry about downloading drivers. (Well, on Mac, you would need Mac Core Audio if you’re wanting to use sample rates other than 48khz - but since you said you are just getting into recording - just ignore that and keep things simple.)
 




Trending Topics

Top Bottom