BB Preamp review: is there an ever-present high fizz?

Discussion in 'Effects, Pedals, Strings & Things' started by MikeSelmer, Feb 28, 2006.

  1. MikeSelmer

    MikeSelmer Member

    Messages:
    261
    Joined:
    Oct 2, 2004
    Hi all! I just got a BB Preamp to try from my local dealer. Tried it yesterday at band volumes and I'm digging the basic tone. I'm using it to bring an already very overdriven Marshall 30th Anniversary head into modern high gain RHYTHM sound (like Weezer). So far I like especially how the BB retains note clarity even at high gain settings. Also, the notes seem to pop out of the guitar very easily, yet don't sound too biting. Overall, it's a very nice modern high gain crunch: ballsy and warm, and the midrange doesn't take over. The mids seem to be quite a little pronounced (which I like) without the sound losing tightness. Especially the lows sound tight, which is kin of surprising to me.

    But there's one drawback that I've found: there seems to be an ever-present high EXTRA FIZZ when playing with high gain? It's a kind of an extra sound that sits on top of the basic sound. Has anybody else experienced this or is it juts my rig? In a way it sounds, I quess, somewhat modern and my be just the design (not a flaw) and something that I've not used to with my previous gear. But I can't dial it out with the tone knobs - only putting less gain helps.

    Please tell me about your expreriences to help me deside whether it's a keeper or not! Thanks!

    MIKE
     
  2. Cary Chilton

    Cary Chilton Senior Member

    Messages:
    4,475
    Joined:
    Aug 8, 2005
    Location:
    Canada
    scott peterson might want to chime in?
     
  3. Baby Evil

    Baby Evil Member

    Messages:
    234
    Joined:
    Jun 13, 2005
    I haven't noticed any fizz at all on my Fender amps, even when using it with my other stomps. I've played it in the shop on a Dual Rectifier (did have some fizz, but I think that's because of the DR) and a Blues Deluxe, no fizz.
    Haven't tried it on a Marshall.

    Jan
     
  4. Matt Gordon

    Matt Gordon Senior Member

    Messages:
    947
    Joined:
    Sep 30, 2004
    Location:
    Georgia, USA.
    I never had the BB, but I always got a little highend crackle with my RC that wasn't too cool. But I was using a different head, a modded Laney VH100R. The RC and the Laney's input stage seemed to conflict. Could be the amp is just not overly pedal happy, or possibly a bad componet in the pedal itself.
     
  5. MikeSelmer

    MikeSelmer Member

    Messages:
    261
    Joined:
    Oct 2, 2004
    Oh my, how probable is this? I don't feel like bying a new pedal with flaws. How about the rest of you BB users - anybody experienced this?
     
  6. Todd Lynch

    Todd Lynch Member

    Messages:
    2,962
    Joined:
    Aug 26, 2005
    Pushing a clean or distorted 6L6 amp with gain as high as 3 o'clock on the BB, I'm not getting (noticing/hearing) any high end fizzing or any other artifacts. I have used it to push a friend's Marshall, but the amp's basic sound was just breaking up, not already 'distorted' - I had no issues with the BB in this case either.
     
  7. Big Bob

    Big Bob Guest

    I've never had a problem with artifacts on a BB. I'm using it into a pushed but not distorting amp. What channel are you using it on your Marshall. (Those are sweet amps BTW) Have you tried any other pedal in that channel? How do you power that BB?

    Bob
     
  8. Yek

    Yek Member

    Messages:
    1,186
    Joined:
    Dec 28, 2003
    Location:
    Netherlands
    My Robotalk (also Prosound) emitted a continuous high freq background tone. But only when using 9v power. Did you already try batteries with the BB?

    I heard that Prosound acknowledged the Robotalk issue . May have something to do with the map's input stage (see Matt's answer). Like some people have noise problems with the Tonecore pedals.

    My RC Booster on the other hand gives no problem.
     
  9. MikeSelmer

    MikeSelmer Member

    Messages:
    261
    Joined:
    Oct 2, 2004
    I'm using the BB on the second channel of the amp (crunch channel) with the gain almost maxed - could this be the culprit? As for the powering issue, I've only tried the BB with batteries.

    This is getting interesting with people coming up with similar fizz comments about other Xotic stuff...something new to discuss about the Xotic line.
     
  10. Scott Peterson

    Scott Peterson Staff Member

    Messages:
    36,849
    Joined:
    Jan 3, 2002
    Location:
    Michigan
    I have used the BB extensively with Fender type amps and Marshall type amps - gain up all the way and down almost all the way down and everywhere in between.

    Never any fizz at all. Something isn't right; I'd contact them. They are very responsive.
     
  11. Unburst

    Unburst Member

    Messages:
    4,221
    Joined:
    Jan 19, 2004
    Location:
    Portland, OR
    Never had a fizz problem with my BB.
     
  12. tybone

    tybone Member

    Messages:
    1,079
    Joined:
    Oct 3, 2004
    Location:
    Ontario
    I have used my BB on a BluesBreaker Combo that had everything on 10 and into a Victoria Tweed Tremolux. Super tone (the thing nearly made me cry a couple of times), no noticable non musical artifacts and certanly no Fizz.
     

Share This Page