Boss Blues Driver BD-2 Question

turbowine

Member
Messages
2
My Boss Blues Driver BD-2 defaults to "on" when I turn on my power supply. Is this normal? All my other pedals (different brands) default to "off" which makes more sense to me. It's mildly irritating because I have to go turn it off each time I power up the setup, if I want to use different things. Imagine if everything defaulted to "on" when power was applied? It would be a nightmare,right? Having to go through and turn off everything you didn't need at that time? Seems to me "off" is the desired power-up state. So is BOSS just presumptuous, or is something wrong with my pedal. (It's been this way since brand new.) I don't have a lot of pedals, so I guess I don't know what is most common -- default on or default off when plugged in to the power?
 

Kevy_Metal

Member
Messages
4,481
Yup, that's normal - at least for me and from what I've heard. That kind of thing shouldn't be an issue, though. My amp is never turned on when my board or pedals are connected to a power supply. I connect everything, turn on the board's power, and then fire up the amp. It just a matter of turning off the Boss pedal before you do that.
 

cap10kirk

Member
Messages
10,023
It's normal. Some Boss pedals are engaged when powered on, some are bypassed. You can modify them to change the powered on state if it bothers you enough. But nothing is actually wrong with the pedal.
 

OotMagroot

Silver Supporting Member
Messages
11,735
The BD needs to stay powered on. You seen Ghostbusters? Remember when Walter Peck ordered the Containment Unit shut off?
 

Blakemore

Silver Supporting Member
Messages
781
My waza blues driver is ON on power up unless a battery is inside the pedal.
With a battery inside and running off my pedal power plus, it’s powers up off.
Might give that a try.
 

JELIFISH19

Member
Messages
973
My waza blues driver is ON on power up unless a battery is inside the pedal.
With a battery inside and running off my pedal power plus, it’s powers up off.
Might give that a try.
Weird. Mine defaults to off. Same as my SD-1W. But my FZ-1W, CP-1X, MO-2, TE-2 and RE-2 default to on. The ones that start on are annoying because I have to turn 4 pedals off when I plug my PS in.
 

musicman1

Member
Messages
5,413
I think mine does too or at least does every so often. Someone here posted a way to stop it from happening but it only works temporarily.
 




Trending Topics

Top Bottom