Boss DD2 engage delay on footswitch

Discussion in 'Effects, Pedals, Strings & Things' started by whitepapagold, Jan 15, 2015.

  1. whitepapagold

    whitepapagold Member

    Messages:
    695
    Joined:
    Nov 25, 2006
    Location:
    rectum of a dead skunk
    Was curious if anyone knew why there is a few second delay before the foot switch of my Boss DD-2 delay pedal works once a cable is plugged into the input jack?

    As in- I plug the cable in, but the foot switch won't work for a few seconds, then it works perfectly!

    After the few seconds delay, it works instantly- on and off with one press- until the input jack is unplugged. Then if you plug back in, there is a couple second delay then voila- working perfect again.

    Happens every time. And its 100% consistent.

    Anyone know why that is?

    BTW- its not an issue or complaint. The pedal works great and sounds incredible- I prefer it over my analog DM-2 and Maxon AD900 by FAR!

    Just curious!
     
  2. stinkfoot

    stinkfoot Member

    Messages:
    6,099
    Joined:
    Jun 20, 2004
    Location:
    Uppsala, Sweden
    They all do that. And it's the same with the early DD-3 (which is the same circuit as the DD-2), and while I'm not 100% sure why, I suspect it is a feature they added to stop it making funny noises while the delay circuit is powering up.
     
  3. whitepapagold

    whitepapagold Member

    Messages:
    695
    Joined:
    Nov 25, 2006
    Location:
    rectum of a dead skunk
    Awesome! Thanks for the response!!!
     

Share This Page