BOSS ES8 Editor "MIDI Connection Error" nightmare!

Messages
10
Hi everyone,

Hope someone can help me here. I have just bought the BOSS ES8 and decided to try editing its settings using the BOSS ES8 Editor software. Unfortunately, when I tried to connect the ES8 to my iMac using my usual USB / Keyboard MIDI connector, the ES8 editor kept saying "MIDI Connection Error".

So I looked it up on the web to see if anyone else was having the same problem. Many were. And one guy suggested that the Roland UM-1 was the answer. So I ordered one.

It arrived. I connected it up. But I still have exactly the same problem, except Roland have now had another £30.00 from me. So before I fly to China, or Japan, or wherever they make this ES8 editor and set fire to them, can anyone please tell me if they've had the same problem and found a fix?

All help gratefully received!

Mark James Ross,

Manchester, UK
 

Fr3shMak3r

Whatever
Platinum Supporting Member
Messages
544
A few things come to mind to verify/try:
  1. Make sure both input and output are connected
  2. Try swapping in and out in the connection - the MIDI interface I’m using, the “out” cable connects to the in, and in the out, which wasn’t intuitive at first.
  3. In the editor, make sure to select the midi interface as the in and out source. If you get errors, check that again - I had a sort of infuriating problem where it would “forget” this setting and it took a few tries to stick.
I definitely had some frustrations with it, so you aren’t alone, but I did get it working eventually!
 

Fr3shMak3r

Whatever
Platinum Supporting Member
Messages
544
Oh, one more thing. Make sure there’s nothing else connected in between. Plug your interface directly into the Boss. I initially tried to connect through a patch bay I have on my board, and it wouldn’t work at all.
 

CarlGuitarist

Member
Messages
3,432
Death by fire seems a little harsh I must say..

Anyways, for starters the UM-1 has a little COMP/TAB. Make sure it's set to COMP. Then make sure you have the latest and correct drivers for the UM-1 installed on your computer. Also make sure you have the latest firmware installed on the ES-8 itself.
 

Steve73

Member
Messages
4,981
Make sure you are on the latest version of the firmware for both the editor and the ES8. I remember getting that error with mine a couple times and it was because either needed to be updated first.
 
Messages
10
Hi all,

Many many thanks to each of you for taking the time to help. REALLY appreciated. The solution was indeed to update the ES8 version first. Once I did that the rest fell into place. Hopefully Roland will make the process a little more intuitive. And either way, an online tutorial video from them would be a great idea. As Fr3shMak3r says, we're not the only people who have torn some hair out over this!

To summarise:

I bought the BOSS UM-1 MIDI interface and connected it to my laptop and BOSS ES8
I set the UM-1 to the 'COMP' setting
I then went to www.roland.com, downloaded and unzipped the BOSS ES8 installer ( "ES-8 Editor Installer.exe" )
It installed OK straight away but I kept getting the "MIDI Connection Error" message
I tore all my remaining hair out
I kicked the cat
I then came to the GEAR PAGE and was took the advice of all the gentlemen above

I then searched for the BOSS ES8 software update file ( UpdSMFJ.exe )
I saved it to a folder on my desktop
I made sure my MIDI UM-1 was set to 'COMP'
I made sure my MIDI leads from the UM-1 were all connected to the right INS and OUTS on the ES8
I powered down the ES8
I powered up the ES8 whilst pressing the EDIT button (this showed me that the current software was the old version 1.03)

When I clicked on the icon for the UpdSMFJ.exe file, it showed a button called 'PATH'
On clicking 'PATH' I was able to navigate to the (now unzipped) folder for named "es8_sys_v204"
Inside were two MIDI files, 001UPD.mid and 002APP.mid.
I then went to my ES8, powering it down.
I powered it back up whilst simultaneously holding the 'DISPLAY/EXIT' button and the right arrow button
The ES8 screen message screen said "UPD"
On my laptop, I went back to the UpdSMFJ.exe and selected 'UM-1' from the drop down at the top
I then clicked the 'SCAN SMF' button
The ES8 received the MIDI messages and updated itself (took about 60 seconds)
I powered down the ES8 again
I powered up the ES8 again, whilst pressing the EDIT button (this showed me that the current software was the new version 2.04)

I then opened up the installed BOSS ES8 editor software on my laptop.
It took about 60 seconds or so to download FROM the ES8 all the settings.
These were then visible and editable on my laptop

Success!

Thanks again to you all.

Mark Ross, Manchester UK
 




Trending Topics

Top