BOSS KATANA 刀 amplifiers

Discussion in 'Amps and Cabs' started by john lan, Sep 9, 2016.

  1. vtgearhead

    vtgearhead Silver Supporting Member

    Messages:
    978
    Joined:
    Aug 24, 2016
    Location:
    Burlington, VT
    This has come up before and I believe the answer is to back off on the spring drive. From memory, it's on page 2 of the BTS settings panel.
     
    berumen77 likes this.
  2. berumen77

    berumen77 Member

    Messages:
    308
    Joined:
    Sep 14, 2011
    Location:
    Austin, TX
    Thank you gustavz and vtgearhead, I'll give it a shot. I usually don't use high levels of reverb except when messing with more ambient clean tones. I was playing with the Twin amp in the sneaky amps (playing Yellow Ledbetter/Hendrix type stuff) and put the spring reverb on and started hearing a kind of chirping with knob between 10-12 o'clock. For some reason it was on the high notes on treble strings and seemed to be random to where I couldn't replicate the noise hitting the same note.. Figured it was some kind of sensitivity thing with the preamp signal strength being so high with Volume on max and feeding the reverb module/chip. I may try also lowering the preamp volume and cranking the Master a bit more instead
     
  3. beagle

    beagle Member

    Messages:
    48
    Joined:
    May 21, 2017
    Location:
    Yorkshire
    If you don't need the effects loop and accept that the speaker in the 100 is different, not better, there's no point in spending all that extra money. I gigged with a one channel valve amp with no effects loop for over 20 years.
     
  4. micycle

    micycle Member

    Messages:
    3,775
    Joined:
    Oct 22, 2008
    Location:
    Minneapplesauce, MN
    That's one thing that has annoyed me ever since they started putting the spring reverb in their GT pedals (started with the GT8 I think?) Every time they release a new product with the spring reverb in it that's the first thing I check out to see if it's any better but nope, still has the annoying ping just like it did 10 years ago! You can sort of make it go away with some tweaking but I usually end up just using another type.
     
  5. Scatabrain

    Scatabrain Member

    Messages:
    837
    Joined:
    Jul 21, 2016
    I do need the loop. Today, as a boost. And I do think the 100 speaker is a lot better not just different.
     
    Elantric likes this.
  6. Fasthand

    Fasthand Member

    Messages:
    86
    Joined:
    Apr 1, 2012
    Location:
    NE Ohio
    shame such little love for the 50, mine works perfectly for me
     
    DonaldR, Wildhawk1 and beagle like this.
  7. stratohiker

    stratohiker Member

    Messages:
    1,889
    Joined:
    Apr 21, 2008
    Location:
    Mountains Of Western NC
    I considered it but, just need mucho clean headroom and as much punch/oomph as possible.
    The 50 is a great unit for folks with more basic needs though.
     
    Fasthand likes this.
  8. frthib

    frthib Member

    Messages:
    1,346
    Joined:
    Mar 28, 2012
    Location:
    Québec, Canada
    You're not alone. Have one and love it. Chapman from Anderton is really loving his too as it seem.

    What I like is the closed nature of the amp.. No fx-loop, no speaker out so no distractions
     
    Fasthand and beagle like this.
  9. JCW308

    JCW308 Supporting Member

    Messages:
    6,554
    Joined:
    May 24, 2010
    Guys for the GA-FC on the Katana, the BOOSTER/MOD and DELAY/FX switches - are they actually set to only be able to turn on Booster and Mod together and Delay / FX together? I can't turn just the booster without turning the mod on, and I can't turn delay on without turning on the FX? I don't get it!

    Thanks!
     
  10. Michel347

    Michel347 Member

    Messages:
    381
    Joined:
    Feb 12, 2013
    Location:
    St-Jean, QC
    I love mine, suits my needs perfectly.
     
    DonaldR and beagle like this.
  11. pointblankpb10

    pointblankpb10 Supporting Member

    Messages:
    123
    Joined:
    Sep 7, 2012
    I got a Katana 50 this week, it sounds pretty good clean through the speaker, but when I plug in headphones, the tone is completely different (and unusably bad). I’m not a huge fan of the onboard overdrive tones, so I plan to use pedals for that, but if I use pedals while listening through headphones the tone goes to mush. I’ll try to come up with a better description of what I’m hearing cause I realize I’m not giving much to go off of, but is there a trick to getting the tone to sound good through headphones? Also, I have the latest update (2.0.2 I think) so that shouldn’t be the issue.
     
  12. mj6thbuif

    mj6thbuif Member

    Messages:
    591
    Joined:
    Jan 19, 2016
    I have the head and the 50w combo. With regard to the K50, I still haven't found anything better for the money. I have had mine for almost a year now. I am still curious about the Peavey Bandit. Would love to compare the two as a pedal platform.
     
    Fasthand likes this.
  13. mj6thbuif

    mj6thbuif Member

    Messages:
    591
    Joined:
    Jan 19, 2016
    I don't like the headphone out either. But then again, I've never liked the headphone out on any amp. For times I have to use headphones, using my Vox Amplug is just as good if not better than any amp headphone out I've ever tried.
     
    adauria likes this.
  14. dlguitar64

    dlguitar64 Member

    Messages:
    4,933
    Joined:
    Dec 30, 2008
    Location:
    Durham,NC
    You are incorrect.It turns on/off booster OR mod and delay OR fx depending on which was active when you saved the channel
     
  15. JCW308

    JCW308 Supporting Member

    Messages:
    6,554
    Joined:
    May 24, 2010
    OK that's what I was trying to say. Thanks for confirming. Thats a shame. Bummer
     
  16. Ramboorider

    Ramboorider Member

    Messages:
    540
    Joined:
    Aug 5, 2017
    Location:
    Philly - Wilmington area
    Have you updated the firmware? My understanding is the headphone sounds are a lot better since the update. I’ve never tried it though - just going by what I’ve read...
     
    beagle and Elantric like this.
  17. pointblankpb10

    pointblankpb10 Supporting Member

    Messages:
    123
    Joined:
    Sep 7, 2012
    Yeah I updated it
     
  18. Erjimipey

    Erjimipey Member

    Messages:
    80
    Joined:
    Jun 4, 2017
    And configured it? By going to System, Line Out...
    I find the Rec and Blend modes to work perfectly with my cheap Sennheiser HD 205. The Live setting doesn't sound as defined as the others... YMMV
     
  19. pointblankpb10

    pointblankpb10 Supporting Member

    Messages:
    123
    Joined:
    Sep 7, 2012
    What do you mean by “configured it”? This may be exactly the issue, all I did was take the amp out of the box and plug headphones in (after updating to the latest firmware)
     
  20. dlguitar64

    dlguitar64 Member

    Messages:
    4,933
    Joined:
    Dec 30, 2008
    Location:
    Durham,NC
    I thought you wanted to be able to turn on the boost without turning on the mod which is exactly what the footswitch does as long as you have the knob set to the boost side.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice