• New Sponsor: ShipNerd, Ship Your Gear with Us... for less! Click Here.

Boss TAE issues?

Mr.Dan

Member
Messages
177
Hey guys, anyone who had issues with the TAE? I‘ve seen some posts where the fuse in the amps did blow. It looks like a great all in one alternative to put in my rack when I don‘t want to bring my big helix board and amp. I don‘t use cabs on stage as everyone wants quite stages these days and we all use in ears in stereo. What do you think of the boss overall? I‘ve used a Suhr RL normally into the helix board and just used an ownhammer GNR and the effects of the Helix with my PT 100.
Curious what your experiences are. I‘ve seen steve stevens using it so it can‘t be that bad compared to other load boxes.
Thank you so much
 

scotty31

Silver Supporting Member
Messages
4,343
I've got one and it's performed well in the year i've had it.
I've given it all sorts of challenges too.

SLO100...i'm finicky with units and this amp too. Be it attentuators, loadboxes, pedals, etc. the boss is very good with it.
Park P45, AC30 TB6, Mark III, Lone Star Classic - zero issues with them all.

I even run a 100w NMV JCM800 1959 into it. I had seen reports that the old NMV Marshall types may not have been the best with them. Honestly can't say it's been bad with it.
im getting a Fryette Power Station 2 for other purposes, but i do plan to A/B the two together and see if there is any difference with the PS2 & the TAE.
 

Mr.Dan

Member
Messages
177
Thanks for chiming…did you use it for the attenuation? I wouldn’t need it for that at all since the PT100 has a great master when engaging the effects loop. Did you try it with IEM? What‘s your opinion about the build in effects?
 

scotty31

Silver Supporting Member
Messages
4,343
i dont use IEM's or monitors. It's primarily a loadbox/attenuator.
It's also quite handy adding a loop to amps without them (AC30 & JCM, but also the SLO FX loop is picky, so this eliminates the issue)
the inbuilt effects are alright.
The delays are nice. Boss do delay well in my book.
the reverb is pretty tolerable (i don't much like reverb unless i'm playing with headphones)
I don't use the others.
The IR's/cab sims i felt underwhelmed by, but i've got Ownhammer & Celestions that i find much better.

I can't imagine you'll have any issues with the PT100 & the TAE.
 

harleytech

Member
Messages
153
I have had one for a couple years now and use it with all my NMV amps and it's great !! No problems what so ever.. I primarily use for attenuation .. Works great every time I turn it on... Thinking about buying a second one too.. Just make sure if you do put it in a rack case that it has to vent on the left side. There is a fan on that side..
Could be why the fuses are blowing in your first post Mr. Dan ?? IDK.. ? I have never had a fuse blow.. Ever..
 
Last edited:

Mr.Dan

Member
Messages
177
Thanks @harleytech… great to hear. I wouldn’t use it for attenuation, just for my in ear system without using cabs….maybe it is overkill if I only use it for that…
 




Trending Topics

Top Bottom