• The Gear Page Apparel & Merch Shop is Open!

    Based on member demand, The Gear Page is pleased to announce that our Apparel Merch Shop is now open. The shop’s link is in the blue Navigation bar (on the right side), “Shop,” with t-shirts, hats, neck buffs, and stickers to start. Here’s the direct link: www.thegearpageshop.com

    You’ll find exclusive high-quality apparel and merchandise; all items are ethical, sustainably produced, and we will be continuously sourcing and adding new choices. 

    We can ship internationally. All shipping is at cost.


Can this pu'p be fixed? One pole sounds phased and quiet.

jonny guitar

Member
Messages
324
Hey, just bought this peavey guitar and it has a weird problem with the middle p'up (single coil with set pole peices). When I play the D string I get a weird 1/2 volume of other strings phased sound; the rest of the strings are just fine but the D is screwed.

I know that if the p'up is out of phase, all the strings sound like this but I am stumped as to the single magnet having problems. I am leaning towards..."this p'up is messed up". Any ideas for me?

I got one response on HC: "If it's a traditional strat pickup with magnets as poles I would say that pole has lost it's charge" but he didn't explain what this means or if I could fix it myself.

Thanks in advance for any ideas you may contribute.
 

RvChevron

Member
Messages
2,465
Hey, just bought this peavey guitar and it has a weird problem with the middle p'up (single coil with set pole peices). When I play the D string I get a weird 1/2 volume of other strings phased sound; the rest of the strings are just fine but the D is screwed.

I know that if the p'up is out of phase, all the strings sound like this but I am stumped as to the single magnet having problems. I am leaning towards..."this p'up is messed up". Any ideas for me?

I got one response on HC: "If it's a traditional strat pickup with magnets as poles I would say that pole has lost it's charge" but he didn't explain what this means or if I could fix it myself.

Thanks in advance for any ideas you may contribute.

Try tap on the pole with a screw driver and see if it has as strong a pull as the other poles. If not, it's buzzed and will need to be recharged/re-magnetized.

Happened to me once when I bought a BRAND NEW Dimarzio HS-2 pickup. The low E was weak and all, I checked and the magnet was noticeably weaker than the others. Send it back to Dimarzio and they fixed it and they also threw in a new strap to compensate for my trouble.:MMM
 

jonny guitar

Member
Messages
324
^ thanks for that. The D one is noticeably weaker ie. I can notice a small difference -- like 90% of what the others have; would this be enough to cause what you speak of.
 

RvChevron

Member
Messages
2,465
^ thanks for that. The D one is noticeably weaker ie. I can notice a small difference -- like 90% of what the others have; would this be enough to cause what you speak of.
I don't know. That low E pole on the hs2 before they fixed it had definitely less than just 90% of the others.

I was actually using a small thin steel ruler to test the strength of the polepieces and the low E was noticeably weaker.

Did you contact Peavey and see what they'll do?
 

jonny guitar

Member
Messages
324
^ So far they have chosen to ignore me but I am going to bug them again and see what they think.

Thanks for your input.
 




Trending Topics

Top