CL Score!

Discussion in 'Effects, Pedals, Strings & Things' started by Headshok, Mar 16, 2015.

  1. Headshok

    Headshok Member

    Messages:
    2,461
    Joined:
    Oct 25, 2012
    Location:
    Fultondale Alabama
    I know this is not the most "booteek" effects system but for what it is, I think I got a steal. I just picked up a mint Digitech RP255 for only $50.00! I think I did alright. Have any of you got any hints as to how to maximize this things potential?
     
  2. Headshok

    Headshok Member

    Messages:
    2,461
    Joined:
    Oct 25, 2012
    Location:
    Fultondale Alabama
    Well, not such a good score. Damn thing doesnt work. Lights come on but no sound. Oh well. Damn the demos sounded so good on youtube
     
  3. 9520575

    9520575 Member

    Messages:
    4,089
    Joined:
    May 26, 2011
    Location:
    Boston, MA
  4. Headshok

    Headshok Member

    Messages:
    2,461
    Joined:
    Oct 25, 2012
    Location:
    Fultondale Alabama
    I did some research. May only be the wrong power supply. Digitech uses a 9Vac-130 milliamp power supply. What the guy gave me was a 9Vdc-750 milliamp power supply. Lights up but no sound. Lots of info about this on the Digitech forum
     
  5. SackvilleDan

    SackvilleDan Member

    Messages:
    2,007
    Joined:
    Nov 15, 2009
    Yeah, you'll definitely need AC to make it happen. It should be the same power supply as a Whammy.

    I've got an RP200 with some really neat sounds on it, but never makes my board because I can't run it with any of my Pedal Power supplies...
     
  6. Ryan84

    Ryan84 Member

    Messages:
    3,623
    Joined:
    Aug 11, 2012
    Why not message the CL guy back about it. It's possible he gave you the wrong adapter for it and still has the right one. Adapters are easy to mix up one for the other.
     

Share This Page