Dead Dog (VFE Alpha Dog)

Discussion in 'Effects, Pedals, Strings & Things' started by revelator62, Apr 14, 2015.

  1. revelator62

    revelator62 Member

    Messages:
    175
    Joined:
    Jul 4, 2010
    My VFE Alpha Dog pedal died a couple of weeks ago. I believe it is less than 2 yrs old. When the foot switch is pressed to engage distortion it cuts off the guitar signal (no more sound) but the white led lamp turns on.

    Anyone have had problems with the alpha Dog? how reliable is this pedal? I was hoping it would be as easy as a foot switch replacement but not sure.

    any help appreciated.
     
  2. insubordination

    insubordination Member

    Messages:
    998
    Joined:
    Apr 11, 2010
    Location:
    Syracuse, NY
    Email VFE. They have a good reputation and I'm sure will help you out.
     
  3. Godspeed64

    Godspeed64 Member

    Messages:
    3,864
    Joined:
    Jul 12, 2008
    Location:
    Singapore
    Hi, try to go through the proper channels (emailing builder, then emailing the shop you got it from if the builder doesn't respond) before seeking the instant gratification of forums.

    Parts fail all the time, it's part of the DNA of mechanical items. Good builders or not doesn't make something less reliable when something fails, because anything can happen (supplier mishap, shipping damage, wear and tear, etc.)
     
  4. skronker

    skronker 2010/2013/2015 S.C. Champions Gold Supporting Member

    Messages:
    4,814
    Joined:
    Aug 6, 2008
    Location:
    Aloha from Oahu, Hawaii
    the smart thing to do is contact the manufacturer
     
  5. drbob1

    drbob1 Silver Supporting Member

    Messages:
    21,959
    Joined:
    Aug 9, 2004
    Probably a bad switch-they aren't very well made and frequently fail. Bad solder joint is also in the running. VFE is very good with help on stuff like this!
     

Share This Page