• New Sponsor: ShipNerd, Ship Your Gear with Us... for less! Click Here.

Digitech Jamman express xt issues

Brantleycoker

Member
Messages
433
Hey guys,
I searched for this first so I figured Id start a thread.
I just got a jamman express xt to run stereo and when I power it with my Pedal Power 2 the lights just flash on and off randomly and I can't get the pedal to loop. It will pass signal since it is true bypass. Am I missing something on powering this pedal? Or do I have a bad one? it worked fine with a battery but not while plugged in. Thanks in advance!
-Brantley
 
Messages
1,533
This totally happened to me... the lights just randomly flash at the same time. I got another one but I haven't really had time to check it out
 

WWW

Gold Supporting Member
Messages
1,646
The jamman XT requires 150ma. Outputs 1-4 and 7-8 on the pedal power are only 100ma. You might try output 5 or 6 which deliver 250ma.
 

Tom Von Kramm

Platinum Supporting Member
Messages
7,042
Hey guys,
I searched for this first so I figured Id start a thread.
I just got a jamman express xt to run stereo and when I power it with my Pedal Power 2 the lights just flash on and off randomly and I can't get the pedal to loop. It will pass signal since it is true bypass. Am I missing something on powering this pedal? Or do I have a bad one? it worked fine with a battery but not while plugged in. Thanks in advance!
-Brantley


This means the JamMan EXT isn't getting enough power. Make sure that you are giving it a steady 150 mA.
 

WWW

Gold Supporting Member
Messages
1,646
Please post if using the proper power supply fixed your problem. Otherwise people who come across this thread while searching might think there's a quality issue when it's just user oversight.
 

Don MacMurray

Member
Messages
4
This means the JamMan EXT isn't getting enough power. Make sure that you are giving it a steady 150 mA.
Late to this thread because I just bought Jamman Express XT. It worked for a while but now it's acting strangely. I have a battery in it...all three LED's are flashing and then they go on one at a time and then flash simultaneously again. It lives up to it's name and keeps going in a loop......
;-)
Does this mean the battery is low? The manual says that when all three lights are on, the battery is low but it doesn't mention flashing. Also, can I feed it with 9 volts & more than 150 milli-amps without damaging the pedal?
 
Messages
1,069
Is more than 150 mA allowable, such as outputs 5 & 6 of a Pedal Power 2 Plus?
Yes. I have 2 Jam Man solo XT in Jamsync and getting them the right current mA is crucial. lots of pedals are rated conservatively, these are not. Low battery causes the flicking lights too. Best off not daisy chained too - i've found that also cause issues, if the PSU isn't pumping out as many mA as it says it is.

Mine are hooked up to a t-rex goliath, which is 450ma per out put. no issues, ever.
 

Royce Lovett

Member
Messages
2
Help!!! When I build my loop for my chorus and verse everything works find BUT when I stop the loop to play my bridge and start the loop back into the chorus, there is a delay. This delay is very noticeable. I never had this problem with my RC-3. HELP please. Can this be fixxed? I would like to keep the Jam Man, becuase i love the "Jam Snyc".
 






Trending Topics

Top Bottom