EBS patch cable reliability?

Droptopandy

Silver Supporting Member
Messages
2,050
Anyone using the EBS Premium gold patch cables? I bought a couple a few months ago. I haven’t gigged with them, thanks to Covid cancelling our shows, only been using at home and a few practices, and I’ve reshuffled my board a few times. But with such little use one of them has the wire exposed where the jack meets the wire. The insulation split. This has me hesitant to throw anymore money at these and questioning their toughness.

I like how small they are but if won’t hold up that’s a no go.
 
Last edited:

Flatscan

Silver Supporting Member
Messages
6,685
Mine seem to hold up better than SIS (which I also like - best solderless that I've tried).

I own many now. One did arrive broken new but that is one of many, many and I haven't had any problems since and I bought most of them used.
 

SirJuxtable

Member
Messages
124
I haven't had any problems so far. Mostly home use for the past year or two, but I shuffle things around rather frequently so they certainly haven't been babied.

The brand new "High Performance" version are interesting because they are bigger and thicker than the super slim Premium Gold patch cables, and also much heavier, but have nice grips on them. They feel "heavy duty" but take up a larger footprint and weigh more. Maybe that's a trade off you'd be interested in?
 

zhivago

Member
Messages
1,206
I have a few of the standard ones...about maybe 15 of them, and one went bad just being on my board, with no stress or moving around...a bit disappointing, but the rest of them have been a-ok. I bought all of them at the same time, and the breakdown occurred about a month and a bit in.
 

Chugs

Member
Messages
168
I have used these for a couple of years and plug and unplug pedals multiple times a day with no issues.
 

Jack Luminous

Member
Messages
667
I use the gold EBS gold kind since a good two years, dozens of them, and I shuffled the whole board a hundred times LOL Haven't had a single failure. Crossing fingers !
 

CarlGuitarist

Member
Messages
3,287
I’ve used the standard ones on my Nano board for a couple of years with only one dud. The new high performance ones look sick.
 

cvansickle

Silver Supporting Member
Messages
11,957
Started using these five years ago, the least expensive versions. Both pedalboards equipped with them fully. No complaints, no failures. I think they sound better than the George L cables I used to use.
 

Droptopandy

Silver Supporting Member
Messages
2,050
The one in the pic still works ok. I guess it’s nothing that some black electrical tape can’t fix.
 

skiltrip

Silver Supporting Member
Messages
1,917
I’ve had them for about 6 months on my board. I move things around weekly if not daily sometimes, and so far no issues with EBS. Even if I did see an issue I’d probably just see it as overuse and abuse with the way I redo my board all the time.
 

JJO

Platinum Supporting Member
Messages
353
I haven't had any problems with mine--nothing that even looks like the damage in the pictures. That seems like more than just wear, but some kind of defect; seems like it would be worth pursuing the warranty claim if you have time/energy.
 

Fat tone79

Silver Supporting Member
Messages
1,385
Never had any problems with EBS. I use the regulars not the gold. Have them on 3 different boards. Like others said I would contact them. Save your money and buy the black ones next time. The gold is a gimmick.
 




Top