Echoplex Digital Pro Users -- I need help

Discussion in 'Digital & Modeling Gear' started by phoenix 7, Mar 15, 2008.

  1. phoenix 7

    phoenix 7 Silver Supporting Member

    Messages:
    24,711
    Joined:
    Jun 6, 2005
    Location:
    Ohio
    All I really use my Echoplex for is to create simple loops to practice over, and sometimes to overdub 2-3 parts, to see how they sound together. Simple stuff. But every once in a while, I seem to step on the wrong button and my Echoplex gets into some weird mode where I can't make simple loops anymore -- it waits to record for a few seconds or it stops recording before I want it to, etc.

    How do I reset the thing to its simplest, most basic mode again, so I can go back to making simple loops?
     
  2. phoenix 7

    phoenix 7 Silver Supporting Member

    Messages:
    24,711
    Joined:
    Jun 6, 2005
    Location:
    Ohio
  3. camitchell

    camitchell Member

    Messages:
    124
    Joined:
    Nov 2, 2006
    Okay, I'm not sure there is an easy way to explain how to do that. As you know, it's a super deep unit and I am far from an expert as well.

    The only advice I can give is sit down with the manual and go through some of the basic setup parameters and get comfortable with those.

    Make sure you understand what is going on each time you press the Parameter button and what the green LEDS mean underneath it. The matrix thing of all the edit modes can be confusing at first, but going through each one and learning how to access them will be very helpful and probably even unlock some of the unit's potential for you.

    Sorry I don't have anything more specific at the moment. Good luck!
     
  4. KRosser

    KRosser Member

    Messages:
    14,154
    Joined:
    Oct 15, 2004
    Location:
    Pasadena, CA
    Step on and hold "Record". It will clear it self and be ready to start again.
     
  5. phoenix 7

    phoenix 7 Silver Supporting Member

    Messages:
    24,711
    Joined:
    Jun 6, 2005
    Location:
    Ohio
    Thanks -- this clears some settings but not all of them. Some stuff cannot be cleared this way. It helped, though.

    I went through the manual (not easy to find what you're looking for in it) and finally found out how to reset the unit to factory specs. (It was explained on p. 200 or something. :bkw )
     
  6. KRosser

    KRosser Member

    Messages:
    14,154
    Joined:
    Oct 15, 2004
    Location:
    Pasadena, CA
    Yeah - that's how you clear the loop it was currently working on.

    One of the first things I've learned to look for in gear manuals is where the 'factory reboot' is...;)
     
  7. phoenix 7

    phoenix 7 Silver Supporting Member

    Messages:
    24,711
    Joined:
    Jun 6, 2005
    Location:
    Ohio
    Yeah, no kidding. The only problem is there is no "factory reboot" chapter (or anything like that) listed anywhere in the Echoplex Table of Contents! And the manual is like 300 pages long! Believe me, I've looked for it before. :bkw

    Finally found that info today, though, in an unlikely section called "Parameter Button."
     
  8. Crazyquilt

    Crazyquilt Guitar Dad Silver Supporting Member

    Messages:
    4,268
    Joined:
    Jul 5, 2005
    I just got an EDP, and have had similar problems.

    Answer: Hold down the PARAMETERS button while powering the unit on.

    I'll admit it -- I've been carrying around my manual like some sort of talisman. I wonder how many XP it's worth.
     
  9. andybutler

    andybutler Member

    Messages:
    44
    Joined:
    Jan 8, 2013
    Wow, 2008.
    Dunnow if you found your way to Looper's Delight and got an answer.

    better late than never

    Just need to do a long press of Undo before Recording.

    Sounds like you got into the mode where you can preset the tempo, so just need to go back to normal.
     
  10. Crazyquilt

    Crazyquilt Guitar Dad Silver Supporting Member

    Messages:
    4,268
    Joined:
    Jul 5, 2005
    Ha! Hi andy. I haven't been active on LD for a few years, but I recognize your name. Funny to see that post from when I'd just gotten my EDP. Now it sits unused in my rack & I run a Boomerang III as the center of a stereo rig.
     
  11. Mincer

    Mincer Member

    Messages:
    3,457
    Joined:
    Nov 25, 2006
    Location:
    Tampa Bay area, FL USA
    The Echoplex is still an amazing looper to this day....that is until (if) the Evoloop comes out.
     
  12. oajensen

    oajensen Member

    Messages:
    2
    Joined:
    May 2, 2007
    Any news about the Evoloop?
     

Share This Page