1. The Rules have been updated regarding posting as a business on TGP. Thread with details here: Thread Here
    Dismiss Notice

Eden Metro not putting out the volume...

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by TNJ, Jan 30, 2006.

  1. TNJ

    TNJ Gold Supporting Member

    Messages:
    28,014
    Joined:
    Jan 7, 2002
    Location:
    Granger, IN
    Recently,
    I've had a couple of guys who play bass in bands tell me that my Eden rig (Metro 210 combo with 410 XLT cab underneath) hasnt been able to generate any volume at all. The sounds are still good, but even with the volume up 3/4 of the way to max...the band plays over it easily. This rig used to be able to vibrate the house, and make your jeans flap. I thought it might be tubes (still do), but the solid state channel is soft as well.
    What's up?
    Thanks
    S>
    j
     
  2. Scott Peterson

    Scott Peterson Staff Member

    Messages:
    36,842
    Joined:
    Jan 3, 2002
    Location:
    Michigan
    Just a question, but one that strikes me - does even the solid state side have a tube in the circuit? I don't know anything about it, but that seems to be a question to ask you.
     
  3. TNJ

    TNJ Gold Supporting Member

    Messages:
    28,014
    Joined:
    Jan 7, 2002
    Location:
    Granger, IN
    Good point, Scott.
    Heck....I dunno! :D
    I think I'm gonna let our pal Todd from Wakarusa go over it with his mad skills.
    S.
    j
     
  4. Mark Robinson

    Mark Robinson Member

    Messages:
    7,054
    Joined:
    Sep 9, 2002
    Location:
    Redondo Beach, California
    A previous bass player of ours had a full Eden rig. One gig we were motoring along, and all of a sudden he's hard to hear and there's a burning aroma coming from the back of his stuff. It turned out to be both crossovers in his two cabinets, basically smoking. He finished the gig, running through the P.A. which he hated of course, but that's life. The Eden folks were cool and sent new updated crossovers, which I installed. They were pretty underwhelming.
     
  5. ModelT

    ModelT Supporting Member

    Messages:
    63
    Joined:
    May 12, 2006
    Location:
    The Netherlands
    Hi TNJ,

    I own a Metro with the same diminishing-power-effect.
    Did you get yours back to "jeans flapping power"? If so: How??

    Thanks, Rob
     

Share This Page