Effects than don't suck tone.

Discussion in 'Effects, Pedals, Strings & Things' started by ljdsam, Feb 20, 2008.

  1. ljdsam

    ljdsam Member

    Messages:
    158
    Joined:
    Jan 1, 2008
    Location:
    Sheffield, UK.
    Just spent a very frustrating day looking for a delay and a chorus or similar to go in the FX loop of my new Elmwood Modena 60.

    Everything seemed to kill the tone even when switched off.

    And hardly anything locally available has a "true bypass".

    I tried:
    Boss CH-1 (yuck)
    Boss CE-5 (better)
    Boss DD-6 (so-so)
    Line 6 EchoPark (Muffled)
    T-Rex Replicator (possibly the best but serious £££)
    Fulltone Choral Flange (didn't like it)
    VS H2O (not bad, but no tap tempo)
    T C Nova Delay (pretty good actually).

    So far the winners are the TC Nova and the CE-5, but only the TC was one I couldn't detect any significant tone change.

    What do people suggest?

    Maybe I need new cables!
    [​IMG]
     
  2. rob2001

    rob2001 Member

    Messages:
    16,940
    Joined:
    Jun 16, 2006
    Location:
    Wisconsin
    Some loops alter tone all on thier own. Try running a high grade short cable and seeing how much change there is. Otherwise, length and quality of the cables matter too.

    I had a tube buffered loop installed on an amp and it still alters the tone with good cables and true bypass pedals. It can be a tradeoff of sorts sometimes.
     
  3. CWFurst

    CWFurst Member

    Messages:
    660
    Joined:
    Dec 21, 2006
    I actually like the L6 Echo Park for it's buffer.
     
  4. theinteriorleag

    theinteriorleag Member

    Messages:
    958
    Joined:
    Feb 19, 2007
    Location:
    tn
  5. ljdsam

    ljdsam Member

    Messages:
    158
    Joined:
    Jan 1, 2008
    Location:
    Sheffield, UK.
    I'd heard good things about it too. Maybe the battery was low.

    The DL4 is meant to be good, but they'd run out!
     
  6. bluntage

    bluntage Member

    Messages:
    179
    Joined:
    Apr 15, 2007
    Location:
    Winchester, KY
    It's likely your loop... I have the exact same problem with my Orange Rockerverb 50.
     
  7. greggorypeccary

    greggorypeccary Member

    Messages:
    7,622
    Joined:
    Feb 12, 2006
    Location:
    Raleigh, NC
    I've spent enough time on TGP to realize that every pedal sucks tone, at least to someone's ears.
     
  8. ljdsam

    ljdsam Member

    Messages:
    158
    Joined:
    Jan 1, 2008
    Location:
    Sheffield, UK.
    That's a great idea, wish I'd thought of that. Right, plan: test every cable I have, ditch the iffy ones and start again...
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice