EL34s in a Lone Star Classic?

Discussion in 'Amps and Cabs' started by jaxonmills, Aug 2, 2008.

  1. jaxonmills

    jaxonmills Member

    Messages:
    373
    Joined:
    Mar 14, 2007
    Location:
    Tuscaloosa, AL
    Anyone tried it? How's it sound?
     
  2. HeeHaw

    HeeHaw Member

    Messages:
    4,961
    Joined:
    Sep 11, 2004
    Location:
    VA
    I don't about the classic, but I put EL34's in my rectoverb when I had it and didn't notice much difference in tone.
     
  3. frankencat

    frankencat Guitarded Gold Supporting Member

    Messages:
    11,633
    Joined:
    Sep 1, 2004
    Location:
    Tampa Bay
    I had EL34's in my old Rectoverb and it made all the difference in the world. Go figure.
     
  4. fjs1962

    fjs1962 Silver Supporting Member

    Messages:
    2,275
    Joined:
    Aug 8, 2002
    Location:
    GA
    I tried a set of the Mesa EL34s (some sort of Russian EL34) in my Lonestar and the amp sounded kind of flat compared to 6L6s. I don't think it's a fair comparison though, as the Mesa EL34s were only pulling 16ma which is biased VERY cold for EL34s. The stock Mesa 6L6s that came in the amp only pulled 26ma and the tone got a lot better when I replaced them with a set of Winged C 6L6s that pull 34ma. I guess what I'm trying to say is no matter what you put in the Lonestar try to get tubes that will get the bias warmed up compared to what Mesa puts in the amp.
     
  5. jaxonmills

    jaxonmills Member

    Messages:
    373
    Joined:
    Mar 14, 2007
    Location:
    Tuscaloosa, AL
    thanks guys. fjs that sounds like good advice.
     

Share This Page