Empress ParaEQ hiss (new topic with video)

Discussion in 'Effects, Pedals, Strings & Things' started by SchmidtMusic, Dec 26, 2017.


  1. SchmidtMusic

    SchmidtMusic Member

    Messages:
    198
    Joined:
    Jan 23, 2017
    this is the Sound Im getting. Cranked the amp so the iPhone mic could get it.

    Listen to How the unit ads hiss with No eq'ing going on.

    Also listen to How the boost makes hiss and White noise. Even when its not activated.

    Its version 7 and 5 months old.

     
  2. olbean

    olbean Member

    Messages:
    413
    Joined:
    Feb 22, 2012
    A little hiss being added from the EQ section is pretty normal (even with no EQing going on) because the signal is still going through additional circuity.
    Turning the boost up without being active is strange though - are you sure the pedal is getting powered correctly? You might actually want to try physically moving the pedal, it looks like you've got it directly on top of your power supply - sometimes that can introduce strange interference.
     
  3. SchmidtMusic

    SchmidtMusic Member

    Messages:
    198
    Joined:
    Jan 23, 2017
    I have tried moving it. Same hiss. I just know people tellinh me it should be DEAD QUIET. The hiss is just too much for this Pricy pedal. Loving its features but it shouldnt make this noise.
     
  4. juri

    juri Supporting Member

    Messages:
    1,752
    Joined:
    Apr 10, 2010
    Location:
    Austin,TX
  5. SchmidtMusic

    SchmidtMusic Member

    Messages:
    198
    Joined:
    Jan 23, 2017
    I have emailed them. No Answer yet.
     
  6. The Villano Dude

    The Villano Dude Member

    Messages:
    768
    Joined:
    Dec 28, 2012
    Definitely contact them. Good luck, man!
     
  7. Malcolmallan

    Malcolmallan Member

    Messages:
    258
    Joined:
    Feb 16, 2013
    Empress customer service is superb, I am sure they will help you.
     
  8. WiresDream

    WiresDream Member

    Messages:
    1,362
    Joined:
    Oct 3, 2015
    What power supply are you using and are you using the correct polarity, voltage, and current?
     
  9. SchmidtMusic

    SchmidtMusic Member

    Messages:
    198
    Joined:
    Jan 23, 2017
    Ofc. Truetone cs12.

    Is send for repair
     
  10. DaveKS

    DaveKS Member

    Messages:
    13,684
    Joined:
    Feb 26, 2013
    Location:
    KS
    So Thomann sent it back and said there nothing wrong with it?
     
  11. SchmidtMusic

    SchmidtMusic Member

    Messages:
    198
    Joined:
    Jan 23, 2017
    No. Thomann just recieved Yesterday.
     
  12. Auditory Driving

    Auditory Driving Member

    Messages:
    812
    Joined:
    Nov 20, 2015
    Location:
    Athens, Greece
    are you using a pedal switcher / looper? if yes, does it behave in the same way outside the looper?
     
  13. Auditory Driving

    Auditory Driving Member

    Messages:
    812
    Joined:
    Nov 20, 2015
    Location:
    Athens, Greece
    if yes, keep in mind that the input of some effects is not grounded when bypassed, which results in noise bleed.
     
  14. SchmidtMusic

    SchmidtMusic Member

    Messages:
    198
    Joined:
    Jan 23, 2017
    No i dont :-/
     
    Auditory Driving likes this.
  15. SchmidtMusic

    SchmidtMusic Member

    Messages:
    198
    Joined:
    Jan 23, 2017
    I used it Always on:)
     
    Auditory Driving likes this.
  16. The Villano Dude

    The Villano Dude Member

    Messages:
    768
    Joined:
    Dec 28, 2012
    Good luck. Hope they are able to repair it--I think it's a great pedal when in working order.
     
    SchmidtMusic likes this.
  17. The Villano Dude

    The Villano Dude Member

    Messages:
    768
    Joined:
    Dec 28, 2012
  18. sonichronic

    sonichronic Member

    Messages:
    1,053
    Joined:
    Apr 25, 2016
    Location:
    New York City
    @SchmidtMusic
    I almost sounds if there is another pedal is on before it's going into the EQ.
    like there is a compressor on or something.

    Does It make this noise if the pedal is isolated just plugged into your guitar and amp.
    I'm sure you did because this is usually the first culprit (another pedal before or after that doesn't work well with the new one) but I had to ask because the video it's in the middle of other effects.

    because of this I've started to test every new pedal outside of my signal chain before I threw it in the mix.

    EDIT: thinking about it, it's definitely gotta be another pedal before the paraEQ. perhaps some sort of impedance issue as the only reason it would be making that sound is if there is something entering the input. impedance issue would explain the boost making noise when the circuit is off.
    as mentioned earlier, it's very normal for EQ's to make noise even when at unity. it's extra circuitry and really what they do is boost (and cut) certain frequencies. definitely not THAT much noise though.
     
  19. mxr2000

    mxr2000 Member

    Messages:
    880
    Joined:
    May 6, 2004
    Empress ParaEQ is the most quiet Eq built today. To the OP. ┬┐Did you try using different instruments cables? Some times with noice comes from defective instruments cables.
     
  20. sonichronic

    sonichronic Member

    Messages:
    1,053
    Joined:
    Apr 25, 2016
    Location:
    New York City
    curious to see what the score was with this.
    don't make sense.
     

Share This Page