Fast Track Pro in Logic

Discussion in 'Recording/Live Sound' started by ealward, Feb 9, 2012.

  1. ealward

    ealward Member

    Messages:
    211
    Joined:
    May 26, 2010
    Hey guys, I'm new to home recording (other than garageband). I have a fast track pro running into logic. I'm trying to mic my amp with an sm57 > preamp > Fast track pro > logic. Only problem is that it isn't working for me. Could you run me through this to see if I'm doing a step wrong. Create new audio track, while selecting...step..step....etc. Thanks!
     
  2. fcarpio

    fcarpio Member

    Messages:
    36
    Joined:
    Oct 24, 2011
    Try SM57 > Fast Track Pro > Computer into Logic, skip the preamp. You need to arm the track for recording and you also need to select the correct input on the track for the channel you are recording. I hope this helps...

    Oh, and you may need to turn phantom power ON on the Fast Track Pro.
     
  3. SteveO

    SteveO Member

    Messages:
    14,942
    Joined:
    Dec 27, 2009
    Location:
    Seattle
    Does Logic recognize the interface? Click on Logic (Pro) in the upper left corner, select "preferences", then (I believe) "audio", and it will show in the window that pops up whether Logic is using the interface or the computer's internal input and speakers.

    If the interface is showing up there, then you should be good to go for that.

    Create a new track, and make sure that it is an audio track (as opposed to software instrument or MIDI). Then, make sure that you have the correct input selected in that window, "input 1" should be the default. Also, make sure that the SM57 is plugged into the correct input on the interface.

    Make sure that the interface is getting a solid signal, check the LED on it to see if it responds to your playing.

    Make sure that the track is armed to record (the R on the channel strip should be red).

    This should be about it!

    No need for the phantom power with an SM57.
     

Share This Page