Fulltone Tube Tape Echo: When was it last updated?

Discussion in 'Effects, Pedals, Strings & Things' started by gnugear, Jul 30, 2008.

  1. gnugear

    gnugear Member

    Messages:
    398
    Joined:
    Aug 26, 2003
    I think it's up to version 4? Anyone know when the last update was?
     
  2. PedalFreak

    PedalFreak Supporting Member

    Messages:
    5,420
    Joined:
    Mar 27, 2007
    Location:
    Rockford, IL
    March 2007? I think. I'll ask Mike tomorrow and post an "official answer" for you.
     
  3. PedalFreak

    PedalFreak Supporting Member

    Messages:
    5,420
    Joined:
    Mar 27, 2007
    Location:
    Rockford, IL
    Just had a new revision! 6/2008 v.5!
     
  4. pipedwho

    pipedwho Member

    Messages:
    1,230
    Joined:
    Aug 29, 2006
    Location:
    Sydney, Australia
    I heard version 6 was going to be all digital.

    j/k ;)
     
  5. gnugear

    gnugear Member

    Messages:
    398
    Joined:
    Aug 26, 2003
    Interesting, I sure would like to know what the revision was. There's one in my local store (new) but it's from 2007.
     
  6. gnugear

    gnugear Member

    Messages:
    398
    Joined:
    Aug 26, 2003
    Anyone find out what the revision was?
     
  7. Jay Douglas

    Jay Douglas Member

    Messages:
    201
    Joined:
    May 29, 2008
    There's no new version, that's just a new MANUAL...the only change over the last couple of years is that now they're using a JJ12au7 instead of the New Sensor 12AT7 for the ERASE tube, which has gone to **** apparently, 187 out of 200 failed of the last batch so they returned them to New Sesnor according to Tech@fulltone.
     
  8. Bonenut

    Bonenut Member

    Messages:
    249
    Joined:
    Mar 30, 2005
    Location:
    Northern Cal
    Mine (serial no. 6xx) originally came with a 12AU7 even though the socket has 12AT7 stenciled next to it. Just an FYI.
     
  9. Jay Douglas

    Jay Douglas Member

    Messages:
    201
    Joined:
    May 29, 2008
    Mine too! Back in 2005? JJ changed the 12AU7 for the worse and that's when Fulltone made the switch to New Sensor AT7.
    Now New Sensor's having the Quality issues, and JJ (at some point) changed the AU7 again, so it works really well in the TTE, I have one in mine and it's perfect.
    It makes the repeats sound better.
    I know, it sounds crazy, but (verified by Tech) the erase tube puts out a white noise-like signal in order to erase, and if that is not "correct" the Record Head (which is right next to the erase head) picks up that noise and is heard as distortion, thus making the repeats sound distorted in a bad way.
    I hope I got that right.
    Anyway, the echo repeats (not the guitar sound itself, which is affected by v2 12AX7) sound better/warmer with a JJ12AU7 in RECORD v3 position.
     
    Last edited: Jul 31, 2008

Share This Page