GE200 Serious bug firmware V1.2.2

Discussion in 'Digital & Modeling Gear' started by Henky, Aug 27, 2018.

  1. Henky

    Henky Member

    Messages:
    869
    Joined:
    Jul 24, 2011
    Location:
    Netherlands
    This is bad news... WTF did they do?

    Calling all GE-200 owners. We have an urgent and unfortunate announcement to make.
    We have found a serious bug within our recent release of firmware V1.2.2
    This bug could potentially cause hardware failure if used for a long period of time.

    To avoid damage to your GE-200….
    If you have already upgraded to V1.2.2 then please download the previous firmware V1.2.0 or V1.2.1 and downgrade your machine as soon as possible.
    http://www.mooeraudio.com/?FirmwareUpdate.html

    If you have not updated the firmware, DO NOT attempt to update to V1.2.2
    We have removed V1.2.2 from our website and are working to repair the issue for re-release.

    Apologies and best regards
    Thanks

    MOOER SUPPORT TEAM
     
    ChrisVereb likes this.
  2. EZchair Picker

    EZchair Picker Member

    Messages:
    469
    Joined:
    Feb 26, 2009
    Sounds like they prematurely initiated the self destruct sequence. Probably didn’t mean to do this until the upgraded model was available for sale.
     
  3. ChrisVereb

    ChrisVereb Member

    Messages:
    1,731
    Joined:
    Sep 23, 2014
    Thanks for the heads up, Henky. Probably good to make that a sticky for a bit.

    Sounds like they maybe found the GE200's HCF opcode :)
     
  4. phil_m

    phil_m Supporting Member

    Messages:
    9,883
    Joined:
    Jun 29, 2012
    Location:
    East of the Sun, West of the Moon
    Always a bad idea to let the interns write the new firmware...
     
  5. ljholland

    ljholland Silver Supporting Member

    Messages:
    2,097
    Joined:
    Apr 23, 2009
    Sheesh.

    This is exactly the issue I've called out on the GE300 thread.

    It would be nice to know if this downgrade will blow away your presets.
     
    6Tones likes this.
  6. Henky

    Henky Member

    Messages:
    869
    Joined:
    Jul 24, 2011
    Location:
    Netherlands
    I'm afraid your concerns are well-founded and I must admit that you are absolutely right ... what a mess
     
  7. Trundler55

    Trundler55 Member

    Messages:
    73
    Joined:
    Nov 1, 2017
    Is this official as I can't see anything on their webpage yet?
     
  8. ljholland

    ljholland Silver Supporting Member

    Messages:
    2,097
    Joined:
    Apr 23, 2009
    Who the heck knows. The company has no ecosystem to allow users to sign up for notifications. This is exactly what I was talking about in the GE300 thread.

    What's sad is that this is not hard stuff to fix for a company that serious about doing business. I think the real issue is that Mooer is a manufacturer that is comfortable building hardware but has no clue about product support. They could fix this but my guess is they are oblivious about how.

    My recommendation is that TGPers should hold on any purchases from Mooer until the company gets their act together.
     
    JiveTurkey likes this.
  9. Henky

    Henky Member

    Messages:
    869
    Joined:
    Jul 24, 2011
    Location:
    Netherlands
    Well they did remove V1.2.2 from their website!

    Yes, i just downgraded, all your presets will blow away
     
    jrcorp and 6Tones like this.
  10. ljholland

    ljholland Silver Supporting Member

    Messages:
    2,097
    Joined:
    Apr 23, 2009
    Dang. I only have a handful of presets that I care about. I guess I could just do some screen shots of the settings since import/export is broken on the mac.
     
  11. Trundler55

    Trundler55 Member

    Messages:
    73
    Joined:
    Nov 1, 2017
    Mine says version V1.01 and I had uploaded the latest version but not lost any presets
     
  12. Trundler55

    Trundler55 Member

    Messages:
    73
    Joined:
    Nov 1, 2017
    Henky...where are you getting your info from?
     
  13. Henky

    Henky Member

    Messages:
    869
    Joined:
    Jul 24, 2011
    Location:
    Netherlands
    Facebook: MOOER Audio official GE200 Group
     
  14. Dan Desy

    Dan Desy Member

    Messages:
    2,499
    Joined:
    Jun 24, 2002
    Location:
    Twin Cities, MN
    Facebook? Must be fake, then... ;)
     
    roachone likes this.
  15. ljholland

    ljholland Silver Supporting Member

    Messages:
    2,097
    Joined:
    Apr 23, 2009
    Kinda pathetic that they think a Facebook group is product support.
     
    6Tones likes this.
  16. MaxTwang

    MaxTwang Member

    Messages:
    2,124
    Joined:
    Oct 15, 2007
    GE200 V1.2.2 == SkyNet

    The Singularity is upon us!
     
  17. valdiorn

    valdiorn Member

    Messages:
    236
    Joined:
    Jul 31, 2010
    Location:
    London, UK
    Wow this is ****ed. I don't see a lot of GE300 sales in the near future, even from the die hard Mooer fans on the Facebook group.

    I'm leaving my updated unit turned off until they have a roll-forward fix.
     
    6Tones likes this.
  18. Vintage Corpse Reviews

    Vintage Corpse Reviews Member

    Messages:
    760
    Joined:
    Aug 22, 2017
     
  19. JiveTurkey

    JiveTurkey Trumpets and Tants Silver Supporting Member

    Messages:
    13,823
    Joined:
    Mar 9, 2009
    Darnit.
     
  20. 6Tones

    6Tones Member

    Messages:
    4,931
    Joined:
    Sep 17, 2002
    Location:
    NY
    Just checked have the 1.20 version whew because losing all your patches sucks . This doesn't instill confidence buy any Mooer product ever again unless they resolve this issue with out delay ,no pun intended.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice