Helios Biasing question

Discussion in 'Amps and Cabs' started by tone?, Feb 5, 2015.

  1. tone?

    tone? Supporting Member

    Messages:
    4,522
    Joined:
    Nov 8, 2008
    Location:
    SF Bay Area California
    So I talked to the tech support at Bogner about biasing the Helios but they werent quite clear.

    I put the Helios in 30watt JTM mode and cranked up the master volume and noticed one of the two tubes redplating.

    I opened the amp to check the BIAS and see if it was too hot.
    It was ok.

    Anyway.
    Purchased some fresh tubes since the amp had them in there for over a year.
    When asking the tech at Bogner I told him that the readings for BIAS in current draw were the same in 100 watt mode and low power mode.

    How is that possible??

    The 100 watt mode is around 500v on the plates. so 70% max current draw should be about 35ma. I followed their advice ( and what i have heard from others ) to BIAS at around 60%. Doesnt make a real difference anyway.
    but it low power mode that is putting the tubes to run significantly colder as the current should be around 42ma.
    But when I put the amp in 30watt mode i am still getting the same 32ma readings.

    Has anyone talked to Bogner about this when rebiasing?
    Am I missing something here?

    Does the current draw in 30watt mode not show up the same?
    Just making assumptions here as im not that technically inclined to find more answers.


    thanks for any feedback!
     
  2. trailrun100s

    trailrun100s Member

    Messages:
    3,572
    Joined:
    Nov 10, 2010
    Location:
    Mammoth Lakes, CA
    I would imagine there is something in the circuit that rebiases for the low power mode, no?
     
  3. tone?

    tone? Supporting Member

    Messages:
    4,522
    Joined:
    Nov 8, 2008
    Location:
    SF Bay Area California

    Nope.

    Im actually getting more feedback from George M on this than Bogners tech support.

    Wonderful huh?

    this should be testament on how George LOVEs his work and is a stand up guy.
    I give credit where its due.

    sorry in a bad mood today and having a $3k amp and half assed tech support rubs me the wrong way.
     
  4. tone?

    tone? Supporting Member

    Messages:
    4,522
    Joined:
    Nov 8, 2008
    Location:
    SF Bay Area California
    I think what George is telling me that because the Helios pulls two tubes in variac mode then the bias does not need to change.

    if that is the case then why didnt tech support at Bogner tell me that?
     
  5. tone?

    tone? Supporting Member

    Messages:
    4,522
    Joined:
    Nov 8, 2008
    Location:
    SF Bay Area California
    Ok so George verified that it doesnt need additional Biasing in 30watt mode because it pulls the two tubes.

    just in case anyone else wondered it, here is the info.
     

Share This Page