Helix 2.8?

Discussion in 'Digital & Modeling Gear' started by JHand, Dec 26, 2018.

  1. 2pods

    2pods Member

    Messages:
    27
    Joined:
    Apr 10, 2018
  2. 2pods

    2pods Member

    Messages:
    27
    Joined:
    Apr 10, 2018
    Incidentally both the Helix and the Stomp upgraded directly to 2.81 from 2.7 as easy as you like. I'm loving all the new stuff. Thanks Line6
     
  3. BjarneDa

    BjarneDa Member

    Messages:
    484
    Joined:
    May 7, 2016
    Soo i started to do backups of all my old preset that was done on 2.71 or earlyer with 2.81 i am already waiting for next update LOL no not really but i want to be sure everything is saved with the new FW.
    Dont know if this is a bug or what?
    According to the backup process everything was succesfully but when i open the first preset all blocks except 3 was gone.
    I dont mind as i always have backup so it was just a matter of importing to the first preset slot again
    Hmm..
    Anyone experience the same?
    Another thing i noticed with the backup process is that it sort of have a preset "active" all the time so you can play during the backup i dont know if that was possible before 2.80.
     
  4. JCW308

    JCW308 Supporting Member

    Messages:
    6,429
    Joined:
    May 24, 2010
    Not sure what it is, but the DR Z sounds even better to me now with 2.8. I use it as my clean and crunch amp all in one patch. Love it even more now! I found a couple of great Dr. Z 2x12 cab IRs and WOW just awesome for both clean and dirty.
     
    Last edited: Aug 14, 2019 at 11:13 AM
    MIJLOVER, Guitarzman and mikah912 like this.
  5. Guitarzman

    Guitarzman Member

    Messages:
    568
    Joined:
    May 16, 2016
    +1

    Agreed DR Z sounds great,, I use it with the Powercab Plus and it sounds really really awesome... Using the Dino speaker model /Cannabis Rex on the Powercab :cool:...
    I generally use 1x12 amps- with the Powercab plus but they're all sounding great and true to the real amp modeled as of 2.81...
     
    mmmaslowski likes this.
  6. jaycee

    jaycee Member

    Messages:
    8,263
    Joined:
    Nov 5, 2003
    Location:
    Boston
    I just picked up the Stomp the other day. It was v2.65, if i remember correctly. I was following the instructions to do the update, and i updated the line 6 updater. As i was reading, i confused the hx editor with the updater, and thought i was ready.

    I didn't even see that the instructions said to update the hx editor first, before updating the unit. Guess what dumb-dumb did? I updated the unit first. I didn't even have the editor downloaded. It did update, but now there are no factory presets. I can see the numbers, and the effects assigned to the buttons at the bottom of the display, but no names.

    How should i fix this? I did download the newest version of the editor, finally, but haven't tried to hook anything up. Do i have to reset it and start over? Any ideas?
     
  7. phil_m

    phil_m Supporting Member

    Messages:
    9,711
    Joined:
    Jun 29, 2012
    Location:
    East of the Sun, West of the Moon
    Just do a factory reset on the Stomp - hold down footswitches 2 and 3 while powering up. Then, yes, just download and install the latest version of HX Edit. You’ll be good to go.
     
    jaycee, PDKTDK and thomasjg like this.
  8. jaycee

    jaycee Member

    Messages:
    8,263
    Joined:
    Nov 5, 2003
    Location:
    Boston
    Thanks Phil, i'll try that tonight when i get home!
     
  9. donnievaz

    donnievaz Member

    Messages:
    3,228
    Joined:
    Sep 19, 2006
    Location:
    Southern MD
    The Helix or in my case, the HX Effects don't have polyphonic pitch shifting yet. I keep hearing that it will come in a firmware update but who know's when that will be if it happens at all. I use the Drop with my HX Effects and it works like a champ. The farthest I go is down a whole step and it sounds fine. I think the further down you go the more it effects your tone but that's to be expected.
     
    viden and kdm1218 like this.
  10. DallasD

    DallasD Member

    Messages:
    382
    Joined:
    Jan 5, 2002
    Location:
    Nashville burbs
    As a Helix user, I’m heading to get a Digitech Drop today. Was waiting for the Helix equivalent, but I don’t have a lot of confidence this will be available soon.
     
  11. Frank Ritchotte

    Frank Ritchotte Silver Supporting Member

    Messages:
    5,489
    Joined:
    Oct 12, 2015
    Location:
    Calabasas, CA
    Helix LT firmware 2.81.1 is now live.
    Hot fix for LT only
    1/4" output level resetting upon a power cycle bug.
     
    MojoRisin and Digital Igloo like this.
  12. MojoRisin

    MojoRisin Member

    Messages:
    406
    Joined:
    Jan 29, 2019
    Nice. LT users feeling the love. :beer
     
  13. Blix

    Blix Supporting Member

    Messages:
    21,877
    Joined:
    Mar 11, 2010
    Location:
    Stabekk, Norway
    And my LT is now running 2.81.1 and SOUNDS BETTER THAN EVER! :D
     
  14. JiveTurkey

    JiveTurkey Trumpets and Tants Silver Supporting Member

    Messages:
    13,356
    Joined:
    Mar 9, 2009
    :waiting
     
    2pods, Zakor, Mooselake and 3 others like this.
  15. MojoRisin

    MojoRisin Member

    Messages:
    406
    Joined:
    Jan 29, 2019
    LOL. I was hoping I deleted that before you saw it. :)
     
    2pods and JiveTurkey like this.
  16. JiveTurkey

    JiveTurkey Trumpets and Tants Silver Supporting Member

    Messages:
    13,356
    Joined:
    Mar 9, 2009
    I'M ALWAYS HERE; WATCHING :worried
     
    BoogieZilla, Fireproof and MojoRisin like this.
  17. marcogary

    marcogary Member

    Messages:
    221
    Joined:
    Sep 27, 2015
    Location:
    Marco Island Fl.
    I found a fix for snapshot changes not being indicated on colored rings or by # on the top right of GUI also shows (Helix failed to recall snapshot data properly in EDIT) on 2.81. My main presets have been through many firmware updates and may have some corruption but to rebuild from scratch would be quite a endeavour with hundreds of parameters to be set. So i noticed that if I clear all blocks on edit then "undo" the snapshots work but all the Footswitch and controller settings are lost (another problem) but easier to reconstruct. BUT if you re-save each snapshot individually it appears to fix bug. The presets are fairly complex and use about every block possible. I'll post to customtone. Curious what others find. Named ..Main Variax
     
    Last edited: Aug 15, 2019 at 2:15 PM
  18. gumtown

    gumtown Member

    Messages:
    1,717
    Joined:
    Sep 13, 2010
    Location:
    New Zealand
    EDIT --- SITUATION RESOLVED !!
    NOOB ALERT !! MUST REMEMBER TO SWITCH OFF CAPACITIVE TOUCH FOR GIGS>>>


     
    Last edited: Aug 16, 2019 at 2:53 AM
  19. rednoise

    rednoise Member

    Messages:
    227
    Joined:
    Sep 13, 2007
    Location:
    Boston
    Patch applied without incident. I think I may have been affected by that bug, as the output volume seemed to be curiously inconsistent and I kept checking the levels on my personal presets, but I never took the time to troubleshoot it. Now things seem stable and all's well.
     
  20. MojoRisin

    MojoRisin Member

    Messages:
    406
    Joined:
    Jan 29, 2019
    I get the convenience of that feature for quick editing, but it’s always been more trouble than it’s worth for me. It was only after the 500th time I accidentally grazed a button with a finger that I decided to disable it all together. If I really need to work quickly it’s way faster to just use HX Edit.
     
    kdm1218 likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice