HELP! Amp Question

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by C.SCAN3, Feb 24, 2009.

  1. C.SCAN3

    C.SCAN3 Member

    Messages:
    470
    Joined:
    Dec 8, 2006
    I have a Goodsell Super 7....I was using it today on 7 watt mode with a HBE Power Screamer and a Creation Audio Labs 4.23 Pro....amp was cranked...guitar on 10...and HBE and CAL set moderate. I was digging in on the guitar and the amp cut out and made a real harsh noise a couple of times. What is this all about? Did I almost blow up my amp? Any ideas?
     
  2. rockon1

    rockon1 Member

    Messages:
    11,305
    Joined:
    Aug 12, 2005
    Location:
    Stamford CT
    The kind of sound like when you unplug a guitar without turning down the volume? If so then may its just a bad cord or jack or other connection going into the amp? Not particularly dangerous if so.

    On the other hand Ive yet to overload the front of a tube amp to the point it cut out though. Bob
     
  3. C.SCAN3

    C.SCAN3 Member

    Messages:
    470
    Joined:
    Dec 8, 2006
    Tried the whole cord thing.....played again....this time the amp went totally silent....then came back on. YIKES!
     
  4. Trout

    Trout Member

    Messages:
    7,566
    Joined:
    Jun 23, 2006
    Location:
    Illinois/Far West Burbia
    Goodsell amps are very well built, I would drop Richard a note, and let him know what happened (be specific).

    Those are fairly straight forward amps, If you want a guess,

    Tubes!,

    Most EL84 amps run the output tubes fairly hard. My first guess would be output tube, second guess would be rectifier tube.

    It is always a good idea to keep a know set of working tubes around as backup just for these special occasions.
     
  5. Swarty

    Swarty Member

    Messages:
    1,132
    Joined:
    Dec 16, 2003
    Location:
    Michigan
    My first pass would be output tube as well.
     
  6. C.SCAN3

    C.SCAN3 Member

    Messages:
    470
    Joined:
    Dec 8, 2006
    Yeah...did get a hold of Richard....it was a tube...not sure if it was the EL84 (It was a brand new Genalex Gold Lion Reissue), or if it was the 12AX7. Richard said normally it is the 12AX7 that go first. All is well. Thanks to all those that chimed in.



     
  7. trinian1

    trinian1 Supporting Member

    Messages:
    189
    Joined:
    Jul 13, 2006
    Location:
    Litchfield, IL
    Was the harsh noise like a squeal? What do you mean by harsh noise? I have an S7, too, so I'd like to be on the lookout for anything similar.
     
  8. C.SCAN3

    C.SCAN3 Member

    Messages:
    470
    Joined:
    Dec 8, 2006
    Almost like the noise you would get if you unplug your guitar without shutting off the amp...but a little worse....it also just faded in and out.


     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice