Help! The rice-krispy guys are in my Rivera amp!

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by Srvwannab, Mar 3, 2006.


  1. Srvwannab

    Srvwannab Silver Supporting Member

    Messages:
    2,241
    Joined:
    Nov 15, 2005
    My Rivera R100 Duo 12 has got an intermentent crackling problem in channel one. I was told that the amp was re-tubed prior to buying it-

    From what I can read online should I be guessing pre-amp tubes? Also, from the manual it looks like each of channels "shares" pre-amp tubes so there aren't really any dedicated channel one preamp tubes to replace. Thoughts?

    Thanks!
     
  2. electroid

    electroid Member

    Messages:
    202
    Joined:
    Feb 12, 2006
    Location:
    Atlanta, GA
    Each preamp tube has 2 sections. You might a tube with one bac section. Try swapping the preamp tubes to other sockets. If it's a bad prepamp tube, you'll notice some kind of change of symptom.
     
  3. VintageJon

    VintageJon Member

    Messages:
    155
    Joined:
    Nov 3, 2005
    Location:
    Austin TX
    Yeah, change the pre-amp tubes and see if symptom changes.
    "Re-tubed doesn't mean squat, noisey tubes are everywhere. I know as I've replaced them at No Charge...

    Finding THE tube in a Rivera will be a goodly amount of time as this is a complex machine and often contains many SS devices. If it's a chip or transistor then the tube change won't help... (I shudder every time I see a Rivera come through the door.)

    -Jon
     
  4. Srvwannab

    Srvwannab Silver Supporting Member

    Messages:
    2,241
    Joined:
    Nov 15, 2005
    Thanks, Electriod and Jon-

    One other clue... The symptoms have left the building and I can't recreate the noise. Also, I noticed that when the crackling was going on the channel selector light was kind of flickering.

    Does that point us in a different direction? With the symptoms gone (at least for now) should I just go on my way....?
     
  5. brad347

    brad347 Member

    Messages:
    4,798
    Joined:
    Feb 8, 2006
    Location:
    Brooklyn, NY
    channel light flickering... iffy relay??? tech guys weigh in please.
     
  6. electroid

    electroid Member

    Messages:
    202
    Joined:
    Feb 12, 2006
    Location:
    Atlanta, GA
    Relay possible or it could be the relay driver circuit or relay power supply. It will be very difficult to troubleshoot until the problem comes back.
     

Share This Page