• New Sponsor: ShipNerd, Ship Your Gear with Us... for less! Click Here.

HELP! What does it mean when only my rectifier tube is glowing?

rmpacheco

Member
Messages
455
Today I plugged into my Morgan AC20 Deluxe and got no sound out of it at all. I looked in back and noticed that only my rectifier tube is glowing. All other preamp and power tubes are cold and dead. Any thoughts as to what might be the problem? Fuse perhaps?
 

rmpacheco

Member
Messages
455
actually, looked at the fuse and it seems fine to me...what else could it be? it was playing fine 2 days ago...
 

hogy

Silver Supporting Member
Messages
13,837
The rectifier heater is fed from a different part of the power transformer than the other tubes.

If your observation is correct, it means there is a problem with the 6.3V heater supply (rectifier runs on a 5V heater, different section of the PT). Could be anything from a cold solder joint to a bad power transformer, and a few things in between.

Time to get it checked out by a tech.
 

rmpacheco

Member
Messages
455
thanks for the heads up. i think my tech is out of town...good thing I have a backup but man...I was hoping to gig with my AC20 next weekend.
 

TheAlchemist

Member
Messages
57
I've had a problem with my AC20 before, and after a phone call to Joe, I had it back in my hands fixed in four business days. For free. I'd call him and see if he can get you fixed up.
 

tele_jas

Member
Messages
3,810
Looking at fuses isn't a good way to judge them, they can look fine but still be bad. Doesn't sound like a fuse, but wanted to throw that out ;)
 

rmpacheco

Member
Messages
455
hmm, there may be something to that but what's strange is I just put the fuse back after leaving it out overnight (went to bed in disgust) and now the amp is playing fine. what the...?
 

ken374

Member
Messages
7,029
Happened 1 time when i had the vox handwired, guitar wasnt plugged in and it was on standby. I turned the stand by off then started playing it sounded really weird then i looked at the back and seen the rectifier tube red plating. I shut it off right away a minute later it was fine. So later that week I replace the tube with a nos and never did it again!
 






Trending Topics

Top Bottom