Help with Eventide Timefactor!!!

Discussion in 'Digital & Modeling Gear' started by DBTele84, Jan 14, 2008.

  1. DBTele84

    DBTele84 Member

    Messages:
    57
    Joined:
    Feb 5, 2007
    So I just received the timefactor, however I can get any sound to come out of it? Anyone else have this problem? I looked all over the webpage, and I initialized it. I've tryed everything and can't get any sound. Its on, I can change banks and all kinds of other stuff. Just no output singal whatsoever. Anyone know what to do?
     
  2. aaland_brian

    aaland_brian Member

    Messages:
    697
    Joined:
    Apr 29, 2007
    Location:
    Minnesota
    Check and make sure your cable's inputs and outputs aren't backwarks since the timefactors jacks are different from most pedals since the output jacks are on the right and the input on the left.
     
  3. Teahead

    Teahead Member

    Messages:
    1,378
    Joined:
    Dec 12, 2005
    Location:
    Northern Ireland
    Not wanting to state the obvious or insult your intelligence, but have you double checked where you are plugged into and out from? The Timefactor's ins and outs are what I would call reversed, not to mention both being stereo. I plugged in blind first time and got the incorrect jacks, just thinking there's a chance you've done the same?

    If not, contact them, they are fast to respond and very helpful ... support@eventide.com

    EDIT ... Aaland said it better and obviously quicker than me. :eek:
     
  4. DBTele84

    DBTele84 Member

    Messages:
    57
    Joined:
    Feb 5, 2007
    Haha, yes my cables are connected properly. Man, I hope its not a bad egg. . . .
     
  5. Rock72

    Rock72 Member

    Messages:
    1,644
    Joined:
    Jul 22, 2007
    With mine I just plugged in the cables (as the manual said), and played. Maybe you should return it to where you bought it from to get a new one?
     
  6. DBTele84

    DBTele84 Member

    Messages:
    57
    Joined:
    Feb 5, 2007
    Yeah, it looks like thats what i have to do. . . which blows cause it took a month to get this one . . . sad day.
     

Share This Page