Hotone Soul Press Noise?

Discussion in 'Effects, Pedals, Strings & Things' started by joe2517, May 4, 2016.

  1. joe2517

    joe2517 Member

    Messages:
    204
    Joined:
    Mar 10, 2013
    Hey guys,

    Just received my Hotone Soul Press; really happy with the volume and expression functions but the wah seems to create an loud humming noise when it's engaged. Any other owners have this problem? I want to know if I need a replacement.

    Cheers
     
  2. FriedBrice

    FriedBrice Member

    Messages:
    1
    Joined:
    Sep 17, 2018
    Did you ever resolve this? I'm having the same issue. Took me a while to determine where the noise was coming from, but have narrowed it down to the Soul Press.
     
  3. xcc

    xcc Member

    Messages:
    2,379
    Joined:
    Jan 23, 2016
    Location:
    Denton, TX
    Sounds like a bad unit. I have two of them, neither with noise issues.
     
  4. paulbearer

    paulbearer Member

    Messages:
    4,162
    Joined:
    Apr 14, 2008
    Location:
    51°31'55.2"N 0°10'38.0"W
    One of my boards is all (10) hotone, mooer, donner minis. I daisy chain them straight to a 9v.
    If I use anything but a one-spot adapter, I get noise. One-spot (no power brick, just the wart/cable) = no noise. Also the soul press crackled a bit when I got it from emp or GC used.
    Shot some lube in there and it resolved. Not sure if I like the Soul Press or the Japanese Girl better. Kept my AMT WH-1 to toggle between.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice