I dropped my amp....

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by johnfindlay, Feb 26, 2004.

  1. johnfindlay

    johnfindlay Member

    Messages:
    1,932
    Joined:
    Dec 22, 2003
    Location:
    Great White
    When I turned it on it made a high pitched squealing sound.

    Actually it fell off of a stand on to some cusions-not very hard either-its a Fender prosonic and had just been fixed up.
    I dont look forward to hauling it out of the basement again.

    i have a good tech -just wondering if anyone might know whats causing the sound?- [tube I hope] so I can estimate
    how much the repair bill will be-and whether i have the strength to lift it [back injury tobagganing with my son!]

    JF
     
  2. Hipster Dofus

    Hipster Dofus Member

    Messages:
    2,332
    Joined:
    Mar 24, 2002
    Location:
    Fort Wayne
    Change the tubes in the pre amp, one at a time. If the amp was on when it hit, The hot tubes may have been damaged.
     
  3. scottl

    scottl Member

    Messages:
    17,041
    Joined:
    Apr 11, 2003
    Location:
    Cherry Hill, NJ
    Send it Andy F! My Prosonic mod still remains one of the best mods he ever did according to impartial witnesses. Something about that platform!

    Scott
     
  4. johnfindlay

    johnfindlay Member

    Messages:
    1,932
    Joined:
    Dec 22, 2003
    Location:
    Great White
    ya I'm 99% for the Fuchs mod Scott.
    I've been in touch with him too.

    Thanks.
     
  5. scottl

    scottl Member

    Messages:
    17,041
    Joined:
    Apr 11, 2003
    Location:
    Cherry Hill, NJ

Share This Page