Is it just me or...........

Discussion in 'Amps and Cabs' started by cisspcism, Sep 24, 2008.

  1. cisspcism

    cisspcism Member

    Messages:
    2,080
    Joined:
    May 6, 2008
    Location:
    Downers Grove, IL
    are the Mark series amps just brittle and flubby? I have a mark 3 and man its great for clean but dog meat for overdrive tones. But then again I dont have the graphic eq.
     
  2. clarkram

    clarkram Member

    Messages:
    2,819
    Joined:
    Jan 5, 2002
    Location:
    Woodstock GA
    I ran a MKIII for 12 yrs, I never used the overdrive (or 2nd ch dark rhythm).

    For OD I would just crank it and control with guitar volume. Worked pretty well, but there are other amps that do it better.
     
  3. gainfreak

    gainfreak Member

    Messages:
    377
    Joined:
    Aug 22, 2003
    Location:
    My Computer at the Moment
    Not having the EQ will definitely add to your problem as will the speakers you are using.

    I have a MKIII coliseum head and a MKIV and I can get them to scream and sound tight but they definitely can get tubby if you don't watch your settings!!

    If you have a graphic EQ, try putting it the loop.


    ~R~
     
  4. franksguitar

    franksguitar Member

    Messages:
    3,692
    Joined:
    Dec 6, 2006
    Location:
    Fairfield, CT
    The eq makes all the difference, and yes never turn bass above 4 and I use the bass boost push pull
     
  5. cisspcism

    cisspcism Member

    Messages:
    2,080
    Joined:
    May 6, 2008
    Location:
    Downers Grove, IL
    Well I had the bass at 2 and mids at 5 and treb at 6, I found the key issue, DONT use PRESENCE, once I turned it to 0 things started sounding better
     

Share This Page