1. The Rules have been updated regarding posting as a business on TGP. Thread with details here: Thread Here
    Dismiss Notice

Issue with new RMC3

Discussion in 'Effects, Pedals, Strings & Things' started by srslots, Feb 19, 2009.

  1. srslots

    srslots Member

    Messages:
    114
    Joined:
    Feb 9, 2009
    Location:
    East Village, NYC
    I just bought an RMC3 this past saturday, and set it up on Monday with my gear. Sound wise, it is wonderful. I have had an issue with it though so I am hoping someone can shed some light here.

    I have also emailed Geoffrey Teese about it.

    I have the Wah set up on my board second in line, with only my TU2 before it. It is powered by my Pedal Power 2.

    One 2 different occasions, when the Wah is engaged, when I turn it off, I loose all signal. On Monday this happened, and when I engaged the wah back on, there was a signal with wah, but then when i clicked it off again...no signal at all. This happened a couple of times before it came back.

    This happened again last night, however the signal came back much sooner.

    The power supply is in there flush and tight, and the cables are new and work, so I dont know what it could be. I am worried because I have a gig on Saturday and dont want it crapping out on me...

    Thanks!
     
  2. txbluzmn

    txbluzmn Member

    Messages:
    75
    Joined:
    Aug 13, 2008
    Location:
    Dallas, TX
    could be a problem with the switch, but just to rule out the DC-in jack, put a battery in it and give it a whirl. Geoffrey is great and I'm sure he will contact you soon about the problem.
     
  3. dosmun

    dosmun Member

    Messages:
    1,765
    Joined:
    Mar 17, 2005
    Location:
    Midland, MI
    Sounds like a switching problem.
     
  4. this1smyne

    this1smyne Member

    Messages:
    2,495
    Joined:
    Jul 31, 2007
    Location:
    Mt P. SC
    my switch on my RMC2 gets stuck sometimes... just make sure its a clean on and off (you may have to stomp pretty hard) and it works usually.... you can buy replacement switches for like $10.
     
  5. srslots

    srslots Member

    Messages:
    114
    Joined:
    Feb 9, 2009
    Location:
    East Village, NYC
    If its the switch though, wouldnt it just stay on if stuck? My problem was that the wah went off, but so did all sound all together. Then I would switch it back on, and it all worked with wah on...back off and nothing.
     
  6. srslots

    srslots Member

    Messages:
    114
    Joined:
    Feb 9, 2009
    Location:
    East Village, NYC
    Just got a reply from Geoffrey:

    Hi Saul,

    Since it appears the bypass is not functioning, check the small bare wire connected to the 2 solder lugs on the end of the switch. If you hae access to a soldering iron, reheat, one at a time, the 2 bypass wire ends. It is possible that the solder fractured and the wire is no longer making a good electrical connection on one or the other end.

    Keep me posted.

    Peace, Love, and Wah,
    Geoffrey
     

Share This Page