JHS Sweet Tea...little help please?

Joe Porto

Member
Messages
733
Does anyone have this pedal. I just purchased a brand new one and am having a little trouble. It is going into self oscillation and the whole pedal becomes microphonic (if I tap on the chassis, I hear it through the speakers), but only when stacking both sides, with the 808 side first. Not all the time, and not really when set where I would use it, but if I kick up the gain of the Angry Charlie side past noon, and hit it with the 808, it happens. Also, the 808 side pops when I turn it on with the Charlie side on.

Already tried several guitars, and a new set of cables, and plugged it in to my VL PPII without anything else (it does not take batteries), but still happening. Maybe just the way the pedal is designed? I think its the Charlie side that is oscillating, and to be honest, it has so much gain that I don't even put the drive past 9:00, but it would be nice to do so without blowing my amp or my ear drums.

Thanks for any help you can offer.
 

Twinattack

Member
Messages
1,182
Had the same issue with mine. I couldn't find a way to effectively stack them. Pretty much the reason I sold it. Loved the 808 side though.
 

Joe Porto

Member
Messages
733
Had the same issue with mine. I couldn't find a way to effectively stack them. Pretty much the reason I sold it. Loved the 808 side though.

Thanks. Maybe it's normal then. Not really a problem for me, as I prefer the AC side drive pretty low, and can pound it with the 808 side.

But on their video of the original Sweet Tea, they have both sides pegged at the end of the video, and when I set mine to those settings, it goes into oscillation.

I have an email in to JHS. Just want to make sure there's not something hinky going on like an intermittent ground connection or something.
 

rufe

Silver Supporting Member
Messages
491
i've had issues with their double pedals before. they'll take care of you though...

had a double barrel where the morning glory side was faulty. sent it back in, and it came back with the same problem. sent it back, and they just sent me a new one. that one worked fine, but I still ended up selling it.
 

mntmoses

Member
Messages
76
No problems here and I've had mine for about 3 months now. I also second JHS' customer service. I'm sure they'll get your problem solved in no time.
 




Trending Topics

Top