Klon KTR Humming...need a Tech !

Lespaulsignature 74

Gold Supporting Member
Messages
4,715
My Klon KTR developed a hum and it gets magnified when I hit it with additional boosts and or other OD's.

I sent it out to Alchemy Audio, they tried but couldn't fix the problem, not a knock on Alchemy Audio they have repaired several of my pedals with great results ! I also contacted Mike at Analog Man but he doesn't repair Klons.

I had the Klon modded by JHS and it has two toggle switches installed that increase the db's/boost...this might have something to do with the hum...but it didn't hum after the initial installation ! Curiously...JHS no longer offers this mod ?

The bottom line is I really like the KTR and want it fixed ! Any suggestions would be greatly appreciated !

Thanks,
Ken
 

Lespaulsignature 74

Gold Supporting Member
Messages
4,715
I would start by looking closely at that mod.
I am not a Tech, I wouldn't know what I am looking at. I asked Alchemy Audio to remove the mod but they said there was a 50% chanced I could loose the pedal if they attempted to remove it ...so I left it in !
 

npappas

Member
Messages
530
My uneducated guess is that there could have been a grounding issue introduced with the new "mod". I'm unsure of how to check for that, but is something to ask a tech to look for.

Although, are you sure you haven't added anything to a daisy chain? I used to daisy chain half my pedals, and I found whenever I introduced a digital pedal to the daisy chain, it would cause tons of noise issues with my dirt pedals.
 

Waldo Nova

Member
Messages
278
So your overdrive/gain pedal has hum when you engage other overdrive/gain pedals? Is anyone expecting a different outcome?
 
  • Like
Reactions: jog

Richard Guy

Member
Messages
1,182
with everything up and running, does the 'hum' change tone or disappear when you toutch the added toggle switches?
 

drbob1

Gold Supporting Member
Messages
27,636
And does it do that when it's battery powered and the only thing between your guitar and amp? Does it do it when it's turned off in buffer (Better This Way) mode?
 

Lespaulsignature 74

Gold Supporting Member
Messages
4,715
And does it do that when it's battery powered and the only thing between your guitar and amp? Does it do it when it's turned off in buffer (Better This Way) mode?
It hums when it's the only pedal between my guitar and amp also with battery and or Pedal Power supply. I have not tried it with the buffer off that is something I need to try !
 

drbob1

Gold Supporting Member
Messages
27,636
Yeah, if the problem is with a ground, it may still hum in true bypass. If the problem is with, for example, the charge pump, then it'll only hum in buffered bypass.
 

Lespaulsignature 74

Gold Supporting Member
Messages
4,715
So much for troubleshooting then. The pedal needs to be repaired. Mine is quiet. So the mods probably did it, not to be Captain Obvious.
Yes my pedal was quiet also...even after the JHS mods were installed....then one day it just started humming. I sent an e-mail to JHS and I am waiting for a reply.
 




Trending Topics

Top