Koch Reverb Puzzle

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by Radax, Sep 19, 2004.

  1. Radax

    Radax Member

    Messages:
    484
    Joined:
    Mar 19, 2002
    Location:
    Broomfield, Colorado
    I have a terrific Koch Twintone that the reverb is either ALL ON (turned up to 10) or there is NO reverb at all?? Its "Surf City" at 10 but nothing else? What is the most common cures for this?? I'm not much of an amp guy either.

    ???
    Mike
     
  2. aleclee

    aleclee TGP Tech Wrangler Staff Member

    Messages:
    11,146
    Joined:
    Jan 4, 2002
    Location:
    5868 ft above sea level
    How queer.

    If you can live without the amp for a few weeks, Fat Willie could probably have things at least as good as new. I just dropped off an amp with him last Friday.
     
  3. Radax

    Radax Member

    Messages:
    484
    Joined:
    Mar 19, 2002
    Location:
    Broomfield, Colorado
    Thanks Alec, I'll do it tomorrow.

    Mike
     
  4. aleclee

    aleclee TGP Tech Wrangler Staff Member

    Messages:
    11,146
    Joined:
    Jan 4, 2002
    Location:
    5868 ft above sea level
    FYI, NBS is closed on Mondays and Willie won't be getting into the shop 'til ~4 all next week.
     
  5. Radax

    Radax Member

    Messages:
    484
    Joined:
    Mar 19, 2002
    Location:
    Broomfield, Colorado
    Closes at 4:00!! My heart stops by 11:00

    LOL
    Mike
     
  6. aleclee

    aleclee TGP Tech Wrangler Staff Member

    Messages:
    11,146
    Joined:
    Jan 4, 2002
    Location:
    5868 ft above sea level
    Opens at 4. Willie normally opens up at 1pm. He closes at 10pm. :eek:
     

Share This Page