• TGP is giving away a Strat, Tele, and Jazzmaster. Click Here for full details.
    Click Here to upgrade your account and enter today!

Line6 Helix

Frank Ritchotte

Gold Supporting Member
Messages
6,415
Anybody ever see the message "The Helix device failed to recall snapshot data properly" in HX Edit? It seems perhaps my go-to preset has become corrupted between 2.80 and 2.81. Anybody else have this happen? I just did a factory reset (hold 7-8 during boot) and then re-restored my 2.80 backup again just in case I missed a step, but it's doing the same thing. I also tried restoring just the single preset export from 2.80 and am having the same issue. What's really odd on the unit is i press snapshot stomps the sound changes but the stomp LEDs dont change. then in stomp mode the stomps dont seem to be toggling correctly either... i made this quick video to show what i'm describing.

If i switch from this preset to a new/blank preset and insert the first amp/cab (whowatt!) it sounds normal, and i can adjust the knobs, eg gain, etc and hear the change, but the display is frozen on Drive 5.0... if i press a stomp to change from snapshot 1 to 2 suddenly the Drive knob display values update and snapshots appear to switch correctly...


is my helix sick?! :(

edit: i tried both of these too.
4. Holding footswitch 9+10 on boot restores presets, setlists, globals and IRs (restores factory bundle) "THIS WILL OVERWRITE ALL USER PRESETS AND SETLISTS
5. Holding footswitch 10+11 on boot will rebuild your presets in the latest loaded firmware
Please log a ticket on this
 

Excalibur46

Member
Messages
4
Anybody ever see the message "The Helix device failed to recall snapshot data properly" in HX Edit? It seems perhaps my go-to preset has become corrupted between 2.80 and 2.81. Anybody else have this happen? I just did a factory reset (hold 7-8 during boot) and then re-restored my 2.80 backup again just in case I missed a step, but it's doing the same thing. I also tried restoring just the single preset export from 2.80 and am having the same issue. What's really odd on the unit is i press snapshot stomps the sound changes but the stomp LEDs dont change. then in stomp mode the stomps dont seem to be toggling correctly either... i made this quick video to show what i'm describing.

If i switch from this preset to a new/blank preset and insert the first amp/cab (whowatt!) it sounds normal, and i can adjust the knobs, eg gain, etc and hear the change, but the display is frozen on Drive 5.0... if i press a stomp to change from snapshot 1 to 2 suddenly the Drive knob display values update and snapshots appear to switch correctly...


is my helix sick?! :(

edit: i tried both of these too.
4. Holding footswitch 9+10 on boot restores presets, setlists, globals and IRs (restores factory bundle) "THIS WILL OVERWRITE ALL USER PRESETS AND SETLISTS
5. Holding footswitch 10+11 on boot will rebuild your presets in the latest loaded firmware
Many users had the same problem after upgrading to version 2.81. You must click on the message to close it, and save each snapshot and after everything will be fine
 

tmuka

Member
Messages
726
Please log a ticket on this
will do, thanks.

Many users had the same problem after upgrading to version 2.81. You must click on the message to close it, and save each snapshot and after everything will be fine
thanks, I'll have to try that.

i ended up recreating my main preset Friday by switching back and forth copy/pasting blocks from the broken preset into the a new one. I'm happy to report that the new preset worked workout issue for our 3 weekend services. (and sounded great!)
 

lgbbq

Member
Messages
17
Anyone know if there's somewhere I can get replacements for the rubber feet or what I should look for at the hardware store? I've had my helix on a pedalboard for a couple years and I want to take it off, but it seems I've lost the feet for it
 
Messages
947
I just updated to the newest version of the firmware and it no longer lets me stay on snapshots... instead, it flashes and goes into the pedal settings for that snapshot, and if I want to change snapshots, I have to stomp the two Preset up/down buttons again.

This is probably a setting that can be changed somewhere but it's really annoying, and I can't find anything about it. What's great about snapshots is being able to change tones with just one press. This ruins it.
 

Dave Merrill

Member
Messages
2,451

marcogary

Member
Messages
223
You're right, it does seem he's got that problem, along with the active snapshot not being indicated correctly in HXEdit, if I'm reading it right.

Not sure that qualifies as "many users", but it's still some sort of corruption or other bug. Did that get reported to Line 6 at the time? Was there any resolution?

I wanted to see if others had same issue, so it is reported now to lead product tester.
 

Guitarzman

Member
Messages
617
will do, thanks.



thanks, I'll have to try that.

i ended up recreating my main preset Friday by switching back and forth copy/pasting blocks from the broken preset into the a new one. I'm happy to report that the new preset worked workout issue for our 3 weekend services. (and sounded great!)
Yeah sometimes after an update a patch may get corrupted and re-creating or re-saving it resolves the issue, but really doesn't happen very often, only happened to me once and resaving the patch fixed the issue...
Plus Helix rebuilds presets for you :cool:....
 

Kylote

Member
Messages
4,602
Does anyone get their expression pedal tightening over time? This is a LT. It seems like every couple months I need to break out the allen wrench and loosen it a bit. It naturally gets tight and squeaky over time it seems (or at least mine does). With the LT expression pedal woes I am pretty on top of loosening it a bit when necessary. Wasn't sure if this was normal expression pedal operation or if I should be concerned that I have one of the dreaded flawed units.
 

burningyen

Member
Messages
14,659
Anyone know if there's somewhere I can get replacements for the rubber feet or what I should look for at the hardware store? I've had my helix on a pedalboard for a couple years and I want to take it off, but it seems I've lost the feet for it
I logged a ticket when one of mine tore early on, and they sent me sturdier replacements lightning fast.
 

PearlyGates

Member
Messages
474
It's only rock 'n' roll...but I love it.
Guitar:
Squier Telecaster Classic Vibe Modded.(S.D. Quarter Pound pickups set)
Helix Amp: Placater (right rhythm guitar ) 3Sigma IR Cab: Morgan 2x12"
Helix Amp: REVV RED (Left rhythm guitar and lead ) 3Sigma IR Cab: Friedman 4x12"
 

Spec

Member
Messages
910
Does anyone get their expression pedal tightening over time? This is a LT. It seems like every couple months I need to break out the allen wrench and loosen it a bit. It naturally gets tight and squeaky over time it seems (or at least mine does). With the LT expression pedal woes I am pretty on top of loosening it a bit when necessary. Wasn't sure if this was normal expression pedal operation or if I should be concerned that I have one of the dreaded flawed units.

I get the opposite on my Helix, the pedal loosens up.

Playing at a new church last Sunday and all of a sudden my volume goes max. Thought I accidently kicked the pedal so backed it off a bit. Soon as my foot is off, max volume. Left my foot on it the rest of the set.

I carry an allen wrench cause this has happened before. Weird thing is I don't notice it loosening up over time. The bolt was pretty loose, I probably should check it once in a awhile. Think I said that last time it happened too!
 

Kylote

Member
Messages
4,602
I get the opposite on my Helix, the pedal loosens up.

Playing at a new church last Sunday and all of a sudden my volume goes max. Thought I accidently kicked the pedal so backed it off a bit. Soon as my foot is off, max volume. Left my foot on it the rest of the set.

I carry an allen wrench cause this has happened before. Weird thing is I don't notice it loosening up over time. The bolt was pretty loose, I probably should check it once in a awhile. Think I said that last time it happened too!
Very strange, I loosened mine slightly like 3 weeks ago and yesterday I go to use it and it is pretty tight and squeaky. I am in the window of a faulty unit (purchased new in May 2017) so may be an early sign, not sure.
 

i8guitar

yelling at clouds from outer space
Gold Supporting Member
Messages
621
Do my eyes deceive me or is Scott Holiday from Rival Sons playing a Helix at this show? Start at 20 seconds....

 




Trending Topics

Top