M audio fast track ultra no longer working...getting the run around

Discussion in 'Recording/Live Sound' started by thesauce, Apr 28, 2015.

  1. thesauce

    thesauce Member

    Messages:
    579
    Joined:
    Mar 11, 2010
    Location:
    NYC
    From avid. They bought out m audio and apparently have little interest any supporting the products they acquired. Drivers etc nothing helps. Any input?
     
  2. amphog

    amphog Silver Supporting Member

    Messages:
    3,622
    Joined:
    Nov 28, 2009
    Location:
    NY
    Most computer related products are like computers, throwaways. Usually cheaper to replace than to repair, and not well supported once the next version is available.
     
  3. Geetarpicker

    Geetarpicker Member

    Messages:
    2,606
    Joined:
    Aug 31, 2004
    Location:
    Nashville, TN
    I used to own a Fast Track Ultra and it was quite decent for the price point. I really liked it's built in DSP mixer (something that RME offers but many do not) and it's something most units in that price range lack. That said, with the used prices on these often below $100 you might be best to move on simply due to lack of support.

    I will mention that my favorite interfaces have been RME units. My rack mount RME Fireface 800 is now going on 13 years old, and not only do they still support it (driver wise) they even recently released a new software mixer panel for it with extra features. RME's support is amazing in this day of throw away computer gear.
     
  4. Cosmik de Bris

    Cosmik de Bris Member

    Messages:
    441
    Joined:
    May 2, 2008
    Me too. Their Firewire drivers are useless, my hardware still works. I even offered to fix the drivers for them.
     
  5. thesauce

    thesauce Member

    Messages:
    579
    Joined:
    Mar 11, 2010
    Location:
    NYC
    Well I can tell you this: avid lost a customer for life and I will dissuade anyone from purchasing any product they are affiliated with.
     
  6. RunBeerRun

    RunBeerRun Member

    Messages:
    343
    Joined:
    Jun 10, 2006
    Not sure how well the Avid drivers do/dont work, they are very different. I recommend the old maudio ones if your os supports it.
     

Share This Page