Merged: phase issues with 2 amps & echodrive

Discussion in 'Effects, Pedals, Strings & Things' started by Bo Faulkner, Apr 26, 2008.

  1. Bo Faulkner

    Bo Faulkner Member

    Messages:
    3,828
    Joined:
    Jul 2, 2005
    Location:
    Red Oak NC
    OK here is my dilema.. I have a radial switchbone which solves phase issues between 2 amps but when I engage my SIB echodrive it goes out of phase.. amps are 71 marshall and Germino club 40. Without the echo on and phase setting on the switcher @ 0 degress the sound is great and when set to 180 it goes thin and out of phase .. when I engage the echodrive @ 0 setting it goes obviously out of phase and I have to set it @ 180 . I have used this setup before without issue and the only thing I can think to add is that I recently changed the tube in the echodrive to a 5751 from a 12 ax7.. could this be the culprit?
     
  2. Bo Faulkner

    Bo Faulkner Member

    Messages:
    3,828
    Joined:
    Jul 2, 2005
    Location:
    Red Oak NC
    put a 12 ax 7 back in it and the same thing.. tried switching the outputs on the switchbone.. same thing.. any ideas? Is this normal?
     
  3. VikingAmps

    VikingAmps Member

    Messages:
    395
    Joined:
    Feb 21, 2007
    Location:
    VA
    Try swapping the inputs on the switcher.
     
  4. Bo Faulkner

    Bo Faulkner Member

    Messages:
    3,828
    Joined:
    Jul 2, 2005
    Location:
    Red Oak NC
  5. Bo Faulkner

    Bo Faulkner Member

    Messages:
    3,828
    Joined:
    Jul 2, 2005
    Location:
    Red Oak NC
  6. VikingAmps

    VikingAmps Member

    Messages:
    395
    Joined:
    Feb 21, 2007
    Location:
    VA
    sorry I meant outputs.
     
  7. Bo Faulkner

    Bo Faulkner Member

    Messages:
    3,828
    Joined:
    Jul 2, 2005
    Location:
    Red Oak NC
    tried that .. didnt work
     
  8. Rod

    Rod Tone is Paramount Silver Supporting Member

    Messages:
    16,739
    Joined:
    Nov 29, 2004
    Location:
    Area 51
    It sounds like there is a phase problem with the Echodrive....
    I've been running 2 amps for a few years now...lots of different amps,,and this is a new one on me...it must be the pedal
     
  9. SuperSoundMusic

    SuperSoundMusic Member

    Messages:
    483
    Joined:
    Jun 30, 2005
    Location:
    San Marcos, CA
    Rick over at SIB I'm sure won't mind at all if you email him about it. I'll PM you.
     
  10. ruger9

    ruger9 Supporting Member

    Messages:
    8,270
    Joined:
    Jan 2, 2006
    Location:
    New Jersey
    I seem to remember haveing the same problem when I was using the Headbone with the Echodrive. Doesn't the switchbone have a phase-correct or ground-lift switch?

    I thought the Echodrive was broken and was getting ready to send it back, then diagnosed a phase issue. In the end it didn't matter because I had just switch to the Maxon AD999 & so I sold the Echodrive.
     
  11. Bo Faulkner

    Bo Faulkner Member

    Messages:
    3,828
    Joined:
    Jul 2, 2005
    Location:
    Red Oak NC
    emailed him and waiting to hear back.. I need to clarify.. the echodrive is after the switcher and only affects one amp.. when engaged it flips the phase of the amp it is active on
     
  12. Chuck Snider

    Chuck Snider Supporting Member

    Messages:
    3,942
    Joined:
    Jan 4, 2002
    Location:
    Limbo
    Is the ground lifted on your Echodrive?
     
  13. Bo Faulkner

    Bo Faulkner Member

    Messages:
    3,828
    Joined:
    Jul 2, 2005
    Location:
    Red Oak NC
    Yes I can lift the ground and switch the polarity .. but when I switch the echo off (echo is only in the marshall chain) it goes out of phase.. then I have to switch the polarity switch back

    I have the problem no matter where the lift switch is
     
  14. Chuck Snider

    Chuck Snider Supporting Member

    Messages:
    3,942
    Joined:
    Jan 4, 2002
    Location:
    Limbo


    What I was asking is.. Did you use a two prong adapter for the powercord that powers up the Echodrive?.. sometimes that helps..
    Chuck
     
  15. Bo Faulkner

    Bo Faulkner Member

    Messages:
    3,828
    Joined:
    Jul 2, 2005
    Location:
    Red Oak NC
    oh .. I am using the 3 prong one that came with it
     
  16. Chuck Snider

    Chuck Snider Supporting Member

    Messages:
    3,942
    Joined:
    Jan 4, 2002
    Location:
    Limbo
    try one of those two prong adapter plugs at the end of your echodrives power chord..
    Might work.. certainly quieted down my rig(with Echodrive)
     
  17. Bo Faulkner

    Bo Faulkner Member

    Messages:
    3,828
    Joined:
    Jul 2, 2005
    Location:
    Red Oak NC
    Noise is not my problem at all... would a 2 prong help with phase cancellation? here is my chain:


    guitar> wah> vibe> drive> drive> radial switcher... out 1 goes to Germino and out 2 goes to echodrive then Marshall


    only the Marshall is affected by the echo and if I set the phase setting right when the echo is off it goes out of phase when I turn it on (as in really thin and cheap chorus sounding) .. when I flip the phase setting to the other position it corrects this. Full and thick sounding. It is if the echodrive flips 180 degrees when engaged.. not a problem with one amp and not even a problem with 2 if they are both in the chain with it.. i am trying to do the wet dry thing ala Joe B and this is when it is a problem.

    I can always just kill the Marshall when I want a totally dry tone but the Marshall and Germino together sound fantastic together dry.. My main concern is if there is a problem somewhere or if this is simple how the echodrive is designed.. if this is just how it is I guess i'll have to work with it.
     
  18. Chuck Snider

    Chuck Snider Supporting Member

    Messages:
    3,942
    Joined:
    Jan 4, 2002
    Location:
    Limbo

    Oh my mistake.. I thought you had a electrical "noise" problem.. I was a using a Framptone switchbox between two amps(or both on) were I had to use the two prong thingy..
    Rick @ SIBFX.com is a very cool guy give him a call from the "help/support" area of his site.. He's been very cool and helpful to me. He knows quite a bit...
    Later,
    Chuck
     
  19. Bo Faulkner

    Bo Faulkner Member

    Messages:
    3,828
    Joined:
    Jul 2, 2005
    Location:
    Red Oak NC
    wow just checked out the sib site ... that Echodrive + looks killer! has slam function and pedal controled delay time!
     
  20. Scott Auld

    Scott Auld Staff Member

    Messages:
    11,911
    Joined:
    Nov 6, 2007
    Location:
    Broward
    Bo, I merged your threads. Please don't cross-post the same thing in different forums. Thanks.

    Good luck with the phase issues. Sounds like a headache.
     

Share This Page