Mesa Mk 111 Bias Problem

Discussion in 'Amps/Cabs Tech Corner: Amplifier, Cab & Speakers' started by PLEXIBLE, Oct 13, 2006.

  1. PLEXIBLE

    PLEXIBLE Member

    Messages:
    148
    Joined:
    May 18, 2006
    Only Getting Approx 15ma Bias Current On Tubes. There Is No Bias Adjustment. Anyone Have This Problem Before?
     
  2. hasserl

    hasserl Member

    Messages:
    4,734
    Joined:
    Oct 24, 2004
    Location:
    So Cal
    A full set of voltage readings would help: B+, plates, screens and control grids. Also, method you used to get the current reading.
     
  3. PLEXIBLE

    PLEXIBLE Member

    Messages:
    148
    Joined:
    May 18, 2006
    471v Plate V. Used Single Tube Bias Probe.
     
  4. trdlasvegas

    trdlasvegas Member

    Messages:
    167
    Joined:
    Aug 30, 2005
    Location:
    Las Vegas
    Replace the (2) 50/75V caps in the bias supply.

    -Tony
     
  5. PLEXIBLE

    PLEXIBLE Member

    Messages:
    148
    Joined:
    May 18, 2006
    Thanks Tony. Looking Into It.
     
  6. PLEXIBLE

    PLEXIBLE Member

    Messages:
    148
    Joined:
    May 18, 2006
    Control Grids Pins 5 Reading-50 On Inner 6l6s And -37 On Outer El34s.these V's Are Only 6 And 8 V's Off Per Schematic. Tech @ Mesa Hollwood Said Bias Circuit Is Ok If Grids V's Are Correct. Anyway, Does Anyone Know What The Tube Bias Should Be On This Mesa Mk 111 Running In Simul-class Mode?
     
  7. beefour

    beefour Member

    Messages:
    24
    Joined:
    Oct 15, 2006
    Exactly what problem are you trying to solve?

    15ma of idle is fine.

    Mesa uses fixed bias that makes the amp fall within the linear range of any 'good' tube.

    If there is a problem with the amp, a 'scope is a much better tool than a bias probe.

    If you've read that 'biasing' the amp is necessary to obtain peak performance, this is true, but there are caveats. The difference between 'peak' and average is not spacious, and that's why Mesa doesn't consider it to be an issue, and why they told you all was fine. It's within factory spec in it's current state.

    All else being equal, the most substantive difference is:

    High bias current = shorter tube life
    Low bias current = longer tube life.

    Too low or too high for normal operation? That's a problem to fix. Setting the bias based on idle current alone is no way to acheive 'peak' performance. Like I said, you need a scope and the talent/skill to wield it for that.

    If the amps sounds fine to you, forget about the bias. That's why it comes fixed from the factory.

    Does that help?

    -Bill
     
  8. Carol-AnnAmps

    Carol-AnnAmps Gold Supporting Member

    Messages:
    4,691
    Joined:
    Sep 29, 2006
    Location:
    Pelham, NH
    The transconductance and current for modern tubes are all over the shop compared with the old ones. If you installed another matched pair it would different, maybe drastically. 15mA is very cold whichever way you look at it, and if you scoped it you would it definately have a noticeable notch at crossover. However if your ears like it, who can argue, at least your tubes will last longer !

    At 470V on the plates with -50V bias on the 6L6, it sounds like something you'd get with Sovtek 5881s. They are usually colder for the same negative bias voltage than other 6L6s.
     
  9. beefour

    beefour Member

    Messages:
    24
    Joined:
    Oct 15, 2006
    So we can't use our old receiving tube manuals for accurate specs? Darn. Doesn't have anything to do with this guy's problem. (or non problem, as it would seem) Gm be damned in the power section of a simul class Mesa. If the power tube can stand up to the B+, the amp will work pretty well, regardless of the tube's country of origin or particular spec.
    None of which makes any difference. The amp will still work, and will still fall within expected norms. Which is one of the beauties of that circuit.
    Dead wrong. The class A section has it's own tap, and does a nice job of keeping the low level stuff linear. Which is why I told him that 15ma was fine. Call it cold if you like. Doesn't matter. They're suprisingly linear in simul-class regardless of the tubes you choose.
    Which is the only thing you said that you said that is reasonably correct and not a rash generalization. Too bad you said it in jest.
    Once again, none of which matters to this kid. You may be the double E here, but you don't write like one. I went the ARRL route starting in about '65. Been inside amps since '69. Saw my first Mesa in '80. Seen literally hundreds of them since then, simul class and not. Three in the shop right now (Recto-verb head, Subway Rocket, and DC2) and I don't even do this **** anymore. Too much fun working with the kids at the college. I only take work for special clients or kids who don't have any money for a decent tech.

    Face it. A kid of 13 has as much ability to spread misinformation, and a hell of a lot more time than either of us. If you're going to bother to disagree with me: 1. Answer the kid's question 2. Do your homework.

    You can rest assured that if I bother to spend the time to post, I won't do so without knowing of what I speak. I see that Tim Swartz (Swarty) is also a member here. He can attest to the fact that I'm kind of a dick, and that I bailed him out a few times in the early 90's when he was cutting his teeth.

    Regards,
    Bill
     

Share This Page