My amp seems to be quieter

Discussion in 'Amps and Cabs' started by billthemountain2, May 2, 2016.

  1. billthemountain2

    billthemountain2 Member

    Messages:
    54
    Joined:
    Oct 7, 2012
    I have an AC 15 hand wired Vox. Yesterday at practice, it couldn't get louder than the drums. I checked it with and without my pedal board, and with other guitars. It's definitely the amp. I was plugged into my usual wall outlet.

    I don't know much about tubes. All five were glowing, three large and two small. I couldn't really tell if the tone was different but it sounded pretty much the same, just quieter.

    Any thoughts on what it could be?
     
  2. dougb415

    dougb415 Member

    Messages:
    9,489
    Joined:
    Oct 27, 2005
    Location:
    Urbana IL
    Tubes (or one of them) are probably going out.
     
  3. tmac

    tmac Goldmember Gold Supporting Member

    Messages:
    2,198
    Joined:
    Jun 29, 2002
    Location:
    The Swamp (Gainesville, Florida)
    Agree, my guess is power tubes. Try a frssh set. Sometimes it can be a preamp tube, but I think these Vox run those EL-84 power tubes pretty hard and may need replacing every year if you play it lot and drive it hard, maybe sooner. . Also, usually a rectifier tube either works or doesn't so probably not that one giving u grief.
     
  4. tmac

    tmac Goldmember Gold Supporting Member

    Messages:
    2,198
    Joined:
    Jun 29, 2002
    Location:
    The Swamp (Gainesville, Florida)
    If not tubes then maybe power supply filter cap, or worse - transformer issues. Always suspect tubes first.
     
  5. billthemountain2

    billthemountain2 Member

    Messages:
    54
    Joined:
    Oct 7, 2012
    Great, so even though I see it glowing, it could be a bad tube? I didn't know that.
     
  6. zenas

    zenas Member

    Messages:
    6,666
    Joined:
    Jul 1, 2011
    Yeah tubes can look good and be bad.
    Be nice if they just exploded when they get weak. :)
     
  7. MartinPiana

    MartinPiana Supporting Member

    Messages:
    4,094
    Joined:
    Jun 21, 2006
    Location:
    SoCal
    I like my wimmins like that.
     
    muzishun and joeprs like this.
  8. zenas

    zenas Member

    Messages:
    6,666
    Joined:
    Jul 1, 2011
    Me too !
     
  9. billthemountain2

    billthemountain2 Member

    Messages:
    54
    Joined:
    Oct 7, 2012
    Thanks for all the help folks. goimg to replace my tubes.

    If I buy the same set as what's there now, do I need to bias my amp?

    The amp is supposed to be cathode biased (it's a vix ac15hw) so I think I read that it's just plug and play.
     
    Last edited: May 2, 2016
  10. muzishun

    muzishun Member

    Messages:
    4,913
    Joined:
    Dec 9, 2014
    Location:
    PNW
    Hope it's tubes. Mine that did the same likely has bad power transformer.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice