My MXR Carbon Copy just died :-(

katarzis

Member
Messages
1,251
Opened it to change the modulation settings, plugged it in again and no sound...
Anyone has a clue what happened?
Thanks.
 

The Whiz

Member
Messages
6,096
Mojo sent. I love mine. I haven't monkeyed with my internals. In fact, I don't even use the modulation on mine, I prefer it without. My DMM, on the other hand....
 

hammersig

Member
Messages
1,425
Forgive Stratman, he tends to spew nothing but hate upon this board. I don't have any amnswers as to why your CC died, but I know other here have had a great experience with Dunlop fixing theirs. I think under some circumstances they will do it under warranty as well. You may want to give them a call. Good luck, let us know if you find anything out.
 

Mooncusser

Member
Messages
2,207
I agree w/ hammersig.......(including his take on "certain" help responses!

MXR has wonderful customer service!
Something similar happened to me once and they had it back to me in a weeks time.
What did you do when you opened the box to make adjustments?
Take care-
 

MusicMan7

Member
Messages
314
If you are running it off a battery, try replacing the battery. My friend had one that was not working properly and all that it needed was the battery replaced.
 

jmcerlain

Silver Supporting Member
Messages
1,382
Mine stopped working as well. My problem is the switch which seems to have been an issue with some early ones as I discovered here. I spoke with them and they are going to take care of it, and update the mod circuit to the latest. I got it when it first came out. Great sounding pedal.
 
Messages
7,602
Mine died on Sunday, it was just over a year so technically out of warranty. I emailed Dunlop and they said they'll fix it, so drop them a line.
 

rwijaya

Member
Messages
2,796
drop dunlop a line, they will fix it for free i think. they have been doing it since most of the version1 died of a sudden death.
 

fancychords

Member
Messages
551
Opened it to change the modulation settings, plugged it in again and no sound...
Anyone has a clue what happened?
Thanks.
I had bought two from musician's friend..The first lasted an hour,sent it back, the second one lasted a day..It spooked me so I sent it back and got a Tech 21 Boost DLA and it's been great..With the MXR although it sounded good I felt it was a time bomb..
 

cedjazz

Member
Messages
484
Does the light come on/no sound when you engage it? There's a few threads here regarding sick CC's.
 

JRC4558Dude

Member
Messages
5,926
Man, I'm really interested in the CC, but I'm a little alarmed by the (relatively) high number of "My Carbon Copy just stopped working" threads..:(
 

mahler

Member
Messages
1,399
Mine stopped working as well. My problem is the switch which seems to have been an issue with some early ones as I discovered here. I spoke with them and they are going to take care of it, and update the mod circuit to the latest. I got it when it first came out. Great sounding pedal.
You have the best avatar ever, love Monty Python :D.
 

katarzis

Member
Messages
1,251
Hey guys, thanks for the chear up.
I use it with adapter. I'll try using a battery.
I change the settings back to where it was - no signal.
The led is on when i engage it but i hear only the dry sidnal (no delay).
I e-mailed MXR, and they said i can send them the pedal and they'll fix it to me. (Kudos to MXR!)
 

The Whiz

Member
Messages
6,096
Actually I'd like to amend my previous comment on how I don't use the modulation. I do use it sometimes. It's very subtle, but I really like it. Adds to the organicness of it.

Fingers crossed mine doesn't break. It feels solid enough tho. Sounds like MXR is good at handling any issues too.

Best delay for the price IMO.
 






Top