Nasty ground hum but all wiring looks ok - help!

Discussion in 'Luthier's Guitar & Bass Technical Discussion' started by jeffinaustin, Mar 22, 2006.


  1. jeffinaustin

    jeffinaustin Supporting Member

    Messages:
    1,058
    Joined:
    Jan 3, 2005
    Location:
    Austin, TX
    My Suhr Classic started humming like nothing i've ever heard earlier. Pulled the jack and pickguard off the guitar and all the wiring looks fine. No broken or cracked solder joints and no wires touching each other. Anything else I should look for?

    Thanks
     
  2. Evan Gluck

    Evan Gluck Member

    Messages:
    142
    Joined:
    Feb 25, 2006
    Location:
    nyc
    it sounds definitley like a loose ground wire, trace all the grounds or get an ohm meter to check the string ground in particular, this will be under the bridge or attached to the tremelo claw if it has a trem.
    hope this helps,
    Evan
     
  3. Evan Gluck

    Evan Gluck Member

    Messages:
    142
    Joined:
    Feb 25, 2006
    Location:
    nyc
    Try it with a different amp and cable too before we start ripping the guitar apart.
     
  4. CAFeathers

    CAFeathers Member

    Messages:
    633
    Joined:
    Apr 17, 2003
    Location:
    Vacaville, CA USA
    How do the solder joints actually look? Are they shiney or are they kinda dull looking?
    If they are dull looking you have a bad solder joint and it should be resoldered.
     
  5. jeffinaustin

    jeffinaustin Supporting Member

    Messages:
    1,058
    Joined:
    Jan 3, 2005
    Location:
    Austin, TX
    There are several that are dull looking. I checked both grounds (jack and trem) and both are connected but I'll resolder them just to be safe. Thanks guys!
     

Share This Page